I recently compiled Sybase::CTlib/sybperl/BLK. I needed this because my old Sybase:: did not have BLK module. This is solaris 10 using perl 5.003. I cannot user perl 5.10 because of user testing on this box.

in the directory i compiled, when I run version, I see the following:
This is sybperl, version 2.18

Sybase:Blib $Revision: 1.61 $ $Date: 2005/03/20 19:50:59 $

Copyright (c) 1991-2001 Michael Peppler

DB-Library version: Sybase DB-Library/12.5.1/P-EBF13138 ESD #12/DRV. 2.8/BUILD1251-045/OPT/Tue Jan 31 21:57:10 2006
This is sybperl, version 2.18

Sybase::CTlib $Revision: 1.71 $ $Date: 2005/04/09 09:27:57 $

Copyright (c) 1995-2004 Michael Peppler
Portions Copyright (c) 1995 Sybase, Inc.

OpenClient version: Sybase Client-Library/12.5.1/P-EBF13138 ESD #12/DRV. 2.8/BUILD1251-045/OPT/Thu Jan 12 20:01:42 2006

I then copied the BLK.pm, CTlib.pm and sybperl.pm into the old directory where older version existed.

When I run the version program there, it shows that sybperl is verion 2.10 and not 2.18 (even though I copied the 2.18 version there).

This is sybperl, version 2.10_02

Sybase:Blib $Revision: 1.48 $ $Date: 1999/05/14 17:31:42 $

Copyright (c) 1991-1999 Michael Peppler

Am I missing something here?