Results 1 to 4 of 4
  1. #1
    Join Date
    Aug 2008
    Posts
    464

    Unanswered: can't connect as sysdba

    Hi

    I'm using Oracle 9i. Everything was OK a few weeks ago. In SQLNET.ORA:

    SQLNET.AUTHENTICATION_SERVICES = (TNSNAMES)

    When I try:

    SQL> conn / as sysdba

    I'm getting a message about 'Insufficient Privilieges'.

    I tried through Toad 8.5 and got a message about

    Oracle startup or Initialization in progress.

    I changed the setting in SQLNET.ORA to:

    SQLNET.AUTHENTICATION_SERVICES = (NTS)

    and then I'm able to log on via SQLPLUS but Toad is now giving:

    ORA 01254: TNS:listener could not resolve SERVICE_NAME........

    I checked Listener.ora and found

    Code:
    # LISTENER.ORA Network Configuration File: C:\oracle\ora92\NETWORK\ADMIN\listener.ora
    # Generated by Oracle configuration tools.
    
    LISTENER =
      (DESCRIPTION_LIST =
        (DESCRIPTION =
          (ADDRESS = (PROTOCOL = TCP)(HOST = DXBPS85LT-SHRAZ)(PORT = 1521))
        )
        (DESCRIPTION =
          (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC0))
        )
      )
    
    SID_LIST_LISTENER =
      (SID_LIST =
        (SID_DESC =
          (SID_NAME = PLSExtProc)
          (ORACLE_HOME = C:\oracle\ora92)
          (PROGRAM = extproc)
        )
      )
    which does not contain the db name.

    Getting confused. I tried recreating the listener via NET CONFIG ASSISTANT but it says the details provided are already being used by another listener. I take it, it's the port 1521 in use. I deleted the existing listener.ora and then tried again but got the same message.

    Can some please help?

  2. #2
    Join Date
    Aug 2008
    Posts
    464
    This is my tnsnames.ora:

    Code:
    # TNSNAMES.ORA Network Configuration File: C:\oracle\ora92\network\admin\tnsnames.ora
    # Generated by Oracle configuration tools.
    
    OPTDEMO = 
      (DESCRIPTION =
        (ADDRESS_LIST =
          (ADDRESS = (PROTOCOL = TCP)(HOST = LOCALHOST)(PORT = 1521))
        )
        (CONNECT_DATA =
          (SERVICE_NAME = optdemo)
        )
      )
    I can see that the service name is not present in listener.ora. I even re-created the listener using the NET CONFIG ASSISTANT with a different port but the service name is still absent in the listener.

  3. #3
    Join Date
    Aug 2008
    Posts
    464

    review

    OK, having reviewed the situation, I can log in to the db using the sys user as sysdba but not 'conn / as sysdba'.

    However, can't connect to the db via Toad, as I get

    ora 01033: Oracle Initilization or shutdown in progress.

    Being connected to the db instance as sysdba, when I try to select from global_name, I get a message telling me:

    Database not open: Queries on fixed tables/views only.

    Please please advise on how to get over this hurdl?

  4. #4
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    >I'm using Oracle 9i. Everything was OK a few weeks ago.
    so, you broke a working configuration.
    WHY did you do this?

    open Command Window & issue following command

    SET

    COPY results then PASTE all back here
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •