Results 1 to 5 of 5
  1. #1
    Join Date
    Apr 2011
    Posts
    2

    Unanswered: SQL Server connects only with admin rights

    Hi All,

    I have MS SQL Server running in my local machine and I am trying to access it through .Net application

    The application works fine when I login using admin rights.

    However when I have power user rights, the MS SQL Server refuses to connect

    Connection String used
    Server=LocalHost;Data Source=(Local)\INSTANCENAME;Initial Catalog=U-Select_IBS2_DATA;user id=uselect;password=uselect;Pooling=false;

    Could someone please explain me, why this doesnt work for power user rights?

    Thanks
    Priya

  2. #2
    Join Date
    Apr 2008
    Location
    Iasi, Romania
    Posts
    561
    Provided Answers: 2
    You have to:
    - create a Windows group
    - add your Windows users to that group
    - create a SQL Server login for that Windows group
    Florin Aparaschivei
    DB2 9.7, 10.5 on Windows
    Iasi, Romania

  3. #3
    Join Date
    Apr 2011
    Posts
    2
    Florin,

    Thanks for your response.
    Today I found something wierd

    I changed the connectionstring to

    Server=LocalHost;Data Source=127.0.0.1\INSTANCENAME;Initial Catalog=U-Select_IBS2_DATA;user id=uselect;password=uselect;Pooling=false;

    and it worked fine even for power user
    i.e I replaced (local) with the system IP

    Is the system not able to resove (local) when accessed with power user rights?

    Thanks
    Priya

  4. #4
    Join Date
    Jan 2003
    Location
    Massachusetts
    Posts
    5,800
    Provided Answers: 11
    There could be a difference in firewall settings, between the two users.

  5. #5
    Join Date
    Apr 2008
    Location
    Iasi, Romania
    Posts
    561
    Provided Answers: 2
    can you give us the error message and ID you receive?
    Florin Aparaschivei
    DB2 9.7, 10.5 on Windows
    Iasi, Romania

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •