Results 1 to 3 of 3
  1. #1
    Join Date
    Nov 2009
    Posts
    21

    Unanswered: SSIS Package Issue (Odbc driver)

    Hello:

    I am hoping someone has a good idea on how to solve this issue. I am out of ideas. I did a search. But I have no luck.
    I am currently using Sql server 2005. It is running on Windows 2008 server.
    I am using odbc driver to connect to Progress database.
    The driver name is Merant 3.60 32 bit process sql92 v9.1c.

    I have created a ssis to run on sql server 2005. It runs fine on Visual Studio 2005. But when I moved the package to production server.
    This is the error message that I got when I ran it on ssis.
    error.system.data.odbcexception: Error[hyc00][MERANT] ODBC Progress driver
    [Optional feature not implemented.]

    If I use the odbc driver to test if I can connect. I have no problem at all.
    I have tried loading it directly to msdb instead of using the file system in Integration services. I got exactly the same message. I tried with different options of encryption. Same error message.

    Any assistance will be appreciated.

    Thanks,
    kkmickey

  2. #2
    Join Date
    Oct 2011
    Posts
    1

    ERROR [IM002] [Microsoft][ODBC Driver Manager] Data source name found and no default

    Hi

    I am trying to create a ssis package using progress odbc. Right now i am having trouble of get this going.

    I set up a ODBC and test successfully, but when I tried to create a connetion in the connection manager and tested. I got the following error message.

    ERROR [IM002] [Microsoft][ODBC Driver Manager] Data source name found and no default driver specified.

    Can you please tell me what are the steps that you do through in order to get the ssis working properly.

    Thanks, Sam
    Last edited by slam@danks.com.au; 10-18-11 at 21:18.

  3. #3
    Join Date
    Sep 2011
    Posts
    71
    OK ,please try below solution ,Originaly posts by Simon Lampen
    For anyone interested I had the same issue but with a failed installation rather than an upgrade.

    It was the Sql Native client, and while the sqlncli.dll was in the \Windows\System32 directory there was no entry on the drivers tab of the Data Sources (ODBC) utility (control panel\administrative tools\Data Sources).
    So I uninstalled SQL Native Client in the Add\Remove programs. The dlls however (unfortunately) remained, so I deleted them, then reinstalled the SQL Native Client component separately, and checked that it showed in the Data Sources \ Drivers tab. Also tested a connection to another Sql 2005 machine.

    Then I re-ran the full SQL Express installation and it worked.

    I think perhaps there were registry entries that were not correctly intialised while those files remained.

    Hope that proves useful to someone.
    For more details about your problem go to msdn link below
    [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •