Hi everybody,

I'm having these errors for a while, and could not find a solution for this...


2011-05-25-05.42.10.932376-300 E2721564A704 LEVEL: Error (OS)
PID : 1789958 TID : 1 PROC : db2fmp (2789534) 0
INSTANCE: db2inst1 NODE : 000
FUNCTION: DB2 UDB, oper system services, sqloLoadModule, probe:130
CALLED : OS, -, dlopen
OSERR : ENOEXEC (8) "Cannot run a file that does not have a valid format."
MESSAGE : Attempt to load specified library failed.
DATA #1 : Library name or path, 39 bytes
/home/db2inst1/sqllib/function/ICMNLSSP
DATA #2 : shared library load flags, PD_TYPE_LOAD_FLAGS, 4 bytes
2
DATA #3 : String, 121 bytes
0509-022 Cannot load module /home/db2inst1/sqllib/function/ICMNLSSP.
0509-103 The module has an invalid magic number.

2011-05-25-05.42.10.932832-300 E2722269A757 LEVEL: Error (OS)
PID : 1789958 TID : 1 PROC : db2fmp (2789534) 0
INSTANCE: db2inst1 NODE : 000
FUNCTION: DB2 UDB, oper system services, sqloLoadModule, probe:140
CALLED : OS, -, dlopen
OSERR : ENOEXEC (8) "Cannot run a file that does not have a valid format."
MESSAGE : Attempt to load specified library augmented with object name failed.
DATA #1 : Library name or path, 49 bytes
/home/db2inst1/sqllib/function/ICMNLSSP(shr_64.o)
DATA #2 : shared library load flags, PD_TYPE_LOAD_FLAGS, 4 bytes
262146
DATA #3 : String, 132 bytes
0509-022 Cannot load module /home/db2inst1/sqllib/function/ICMNLSSP(shr_64.o).
0509-152 Member shr_64.o is not found in archive



$ db2level
DB21085I Instance "db2inst1" uses "64" bits and DB2 code release "SQL08026"
with level identifier "03070106".
Informational tokens are "DB2 v8.1.1.120", "s060801", "U808888", and FixPak
"13".
Product is installed at "/usr/opt/db2_08_01".
$ oslevel
5.3.0.0

AIX 64 bit

any idea about this errors?

Thx!
Gustavo