Results 1 to 4 of 4
  1. #1
    Join Date
    May 2010
    Posts
    88

    Unanswered: unable to extract data from CLP

    Hi friendz,
    I have copied a schema using the below command:

    call sysproc.admin_copy_schema ('schema2', 'copysch', 'copyno', 'user1', 'userspace1', 'userspace2', 'COPYSCHEMA', 'COPYERROR')

    I can see the table under the new schema 'copysch' and from control center can also access the data but I am not able to access data from CLP.


    C:\Documents and Settings\user1>db2 select * from copysch.ACT
    SQL0204N "COPYSCH.ACT" is an undefined name. SQLSTATE=42704

  2. #2
    Join Date
    Jan 2003
    Posts
    4,292
    Provided Answers: 5
    I suspect that the sysproc.admin_copy_schema procedure created the new schema as lowercase. If that is the case, then your queries must be like this:

    Code:
    select * from "copysch".ACT
    Andy

  3. #3
    Join Date
    May 2010
    Posts
    88
    Yes, the new schema is created in lower case. But the provided query does not help. I have tried things out and concluded that schema name always has to be in uppercase.
    Thanks for the hint about the case sensitivity

  4. #4
    Join Date
    May 2010
    Posts
    88
    Well, I had one more query. I can find no difference in the copymode option of " copy and copyno" in ADMIN_COPY_SCHEMA. using copy option did not took my database in backup pending state as documented. Can you help me list the difference between these two option?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •