Results 1 to 3 of 3
  1. #1
    Join Date
    Dec 2010
    Posts
    6

    Exclamation Unanswered: Can't find program 'mysqlcheck' Please restart with --basedir=mysql-install-directory

    Hi,

    I am getting the following error message while I am trying to run "mysql_upgrade -uroot -proot --basedir=/" on the root directory - "Can't find program 'mysqlcheck'
    Please restart with --basedir=mysql-install-directory
    ". I am using 5.0.41 community-log edition.

    Doing this mysql_upgrade since I got Error:1307 - Failed to execute Stored Procedure.

  2. #2
    Join Date
    Sep 2009
    Location
    San Sebastian, Spain
    Posts
    880
    If you look at the message returned it says "--basedir=mysql-install-directory". You have passed in the root / directory. Find where mysql is installed and set basedir correctly and retry.
    Ronan Cashell
    Certified Oracle DBA/Certified MySQL Expert (DBA & Cluster DBA)
    http://www.it-iss.com
    Follow me on Twitter

  3. #3
    Join Date
    Dec 2010
    Posts
    6
    When i ran ps -ef | grep mysql it shows "basedir=/" and for whereis mysl it showed me the following paths "mysql: /usr/bin/mysql /usr/lib/mysql /usr/share/mysql /usr/share/man/man1/mysql.1.gz" But when I tried to run from all these paths it is showing same error. for eg, "mysql_upgrade -uroot -proot --basedir=/usr/bin/mysql"

    Whereas I am able run mysqlcheck from the root / directory.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •