Results 1 to 8 of 8
  1. #1
    Join Date
    Jul 2011
    Posts
    10

    Unanswered: linked server to Oracle

    Im trying to create a linked server in sqlServer using the steps from these links:

    How do you setup a linked server to an Oracle database on SQL 2000/2005? - Stack Overflow

    How to setup linked servers for SQL Server and Oracle 64 bit client

    But it keeps giving me this error:

    Error Screenshot

    Any idea whats going wrong?
    Last edited by rickoy; 07-22-11 at 04:22.

  2. #2
    Join Date
    Jul 2011
    Posts
    10
    by the way.... im using sqlsever2008 to link to oracle 11g

  3. #3
    Join Date
    Apr 2008
    Location
    Iasi, Romania
    Posts
    561
    Provided Answers: 2
    ORA-12154 error is thrown during the logon process to a database. This error indicates that the communication software (TNS) in Oracle ( SQL *Net or Net8 ) did not recognize the host/service name specified in the connection parameters.

    Edit: check Host, Port, and Service_name in tnsnames.ora file
    Last edited by aflorin27; 07-22-11 at 04:41.
    Florin Aparaschivei
    DB2 9.7, 10.5 on Windows
    Iasi, Romania

  4. #4
    Join Date
    Jul 2011
    Posts
    10
    Why is that? I have tried to do a connection test in the ODBC Administrator Window and it worked fine. But when I go to sqlServer and use the ODBC connection that I have defined, it keeps giving me this error. I already included my username and password during the definition of the linked server but its still the same.

  5. #5
    Join Date
    Apr 2008
    Location
    Iasi, Romania
    Posts
    561
    Provided Answers: 2
    Are you sure you are using the same DSN?
    Florin Aparaschivei
    DB2 9.7, 10.5 on Windows
    Iasi, Romania

  6. #6
    Join Date
    Jan 2003
    Location
    Massachusetts
    Posts
    5,800
    Provided Answers: 11
    Is the DSN you created a system, or a user DSN?

  7. #7
    Join Date
    Jul 2011
    Posts
    10
    I used a system DNS and placed its name as the Datasource value of the linkedserver i created...

  8. #8
    Join Date
    Jul 2011
    Posts
    10
    thans to everyone here....

    I solved the problem.... I just tried to reinstall the oracle client and driver....

    thanks again...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •