Results 1 to 8 of 8
  1. #1
    Join Date
    Jul 2011
    Posts
    4

    Unanswered: "sys/test@123@dbserver/instance_name" unable to log in to sqlplus, EM is down

    To connect EM with instance i require to reset my sysman password
    for that i need to log in SQLPLUS with sys account, but unfortunately i put my sys password as "test@123" now since i have to enter the string as

    SQL> connect sys/test@123@dbserver/instance

    it shows error as "@" is coming two times

    Please help

  2. #2
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    log onto DB Server then do EXACTLY as below

    sqlplus
    / as sysdba
    alter user sysman identified by new_password;
    exit

    COPY commands above & results then PASTE all back here
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

  3. #3
    Join Date
    Jul 2011
    Posts
    4
    that's the problem
    Last edited by brij; 07-28-11 at 09:09.

  4. #4
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    Quote Originally Posted by brij View Post
    that's the problem
    PROBLEM?
    What Problem?
    I don't see any problem.

    Do EXACTLY as I posted

    It is really, Really, REALLY difficult to fix a problem that can not be seen.
    use COPY & PASTE so we can see what you do & how Oracle responds.
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

  5. #5
    Join Date
    Jun 2004
    Location
    Liverpool, NY USA
    Posts
    2,509
    Quote Originally Posted by anacedent View Post
    log onto DB Server then do EXACTLY as below

    sqlplus
    / as sysdba
    alter user sysman identified by new_password;
    exit

    COPY commands above & results then PASTE all back here
    When she says login into db server, she means exactly that. Login in on the machine where the database is located as the user (normally oracle) that was used to create the database.
    Bill
    You do not need a parachute to skydive. You only need a parachute to skydive twice.

  6. #6
    Join Date
    Jul 2011
    Posts
    4
    you all are so kind, thanks for your response

    here's the output of the command

    SQL> CONNECT / AS SYSDBA
    ERROR:
    ORA-12162: TNS:net service name is incorrectly specified


    tnsnames.ora file


    # tnsnames.ora Network Configuration File: /home/oracle/app/oracle/product/11.2.0/dbhome_1/network/admin/tnsnames.ora
    # Generated by Oracle configuration tools.

    ABC =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = DBserver1)(PORT = 1521))
    (ADDRESS = (PROTOCOL = IPC)(Key = abc))
    )
    (CONNECT_DATA =
    (SERVICE_NAME = abc)
    (INSTANCE_NAME = abc)
    (GLOBAL_NAME = abc)
    )
    )




    listener.ora file

    # listener.ora Network Configuration File: /home/oracle/app/oracle/product/11.2.0/dbhome_1/network/admin/listener.ora
    # Generated by Oracle configuration tools.

    LISTENER =
    (DESCRIPTION_LIST =
    (DESCRIPTION =
    (ADDRESS = (PROTOCOL = TCP)(HOST = DBserver1)(PORT = 1521))
    )
    (DESCRIPTION =
    (ADDRESS = (PROTOCOL = IPC)(KEY = abc))
    )
    )

    ADR_BASE_LISTENER = /home/oracle/app/oracle

    TRACE_LEVEL_LISTENER = USER



    ** ABC is same everywhere i.e my database name

  7. #7
    Join Date
    Apr 2011
    Posts
    17
    SQL> CONNECT / AS SYSDBA
    ERROR:
    ORA-12162: TNS:net service name is incorrectly specified.

    can be solved by setting environment variable oracle_sid.

    if u r running ur oracle database on windows platform then :

    prompt:\> set oracle_sid=abc

    n if linux on platform then :

    prompt:\> export ORACLE_HOME=/oracle/app/oracle/product/11.1.0/db_1 (specify ur oracle home,if not this)
    prompt:\> export ORACLE_SID=abc

    try this.sometimes issues are simple but we make them complicated.

    Best regards.
    Krishan.

  8. #8
    Join Date
    Jul 2011
    Posts
    4
    after analyzing init.ora file i reconfigured all the environment variables
    then i was able to log in threw sqlplus as
    sql> CONNECT / AS SYSDBA

    i altered the sysman account settings, then changed the target.xml file and config.xml file

    i'm able to access the database threw EM now .

    Thank you all for your time and help

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •