Results 1 to 2 of 2
  1. #1
    Join Date
    Jun 2011
    Posts
    63

    Unanswered: Sql Management Studio debugger not working

    Please help, i cant do anything without the debugger.

    When i try to execute a sp, and click step into, the debugger just closes. Any breakpoints i set are labeled "breakpoint will not be hit".

    I couldnt find any settings for debugging. Im using the 2008 version.

    Thanks

  2. #2
    Join Date
    Jun 2011
    Posts
    63
    Here is what i am trying to debug

    Code:
    USE [dbTalesOfEpic]
    GO
    
    	@status tinyint OUTPUT,
    	@mapName char(30),
    	@mapSize tinyint,
    	@backgroundImage char(100)
    
    DECLARE @mapId integer,
            @i tinyint,
            @a integer,
            @b integer
    
    BEGIN TRY
    
    BEGIN TRANSACTION
    
    	SET NOCOUNT ON;
    	
    	Insert Into Maps ([mapName], backgroundImage, mapSize)
    	values (@mapName, @backgroundImage, @mapSize)
    	
    	SET @i = 0
    	SET @mapId = SCOPE_IDENTITY()
    	
    	WHILE @i < @mapSize
    	BEGIN
    		INSERT INTO linkTo (mapLink, locationLink)
    		VALUES (null, null)
    		SET @a = SCOPE_IDENTITY() ---Stores the pk for insert into foreign table---
    		INSERT INTO Links (linksToId, linkTypeId)
    		VALUES (@a, 2) ---@s is the pk of the previous table, and 2 is the entry in linkTypes specifying noLink---
    		SET @b = SCOPE_IDENTITY() ---Stores the pk for insert into foreign table---
    		INSERT INTO mapGrids (tooltip, alternateText, imageUrl, linkId, mapId, nodeName)
    		VALUES (null ,null, null, @b, @mapId, (@mapName + '_' + @i))
    		SET @i = @i + 1
    	END
    	
    SET @status = 1	
    	
    COMMIT
    
    END TRY
    BEGIN CATCH	
    
    	SET @status = 0
    
    IF @@TRANCOUNT>0
    	ROLLBACK
    
    END CATCH
    
    RETURN @status

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •