Results 1 to 7 of 7
  1. #1
    Join Date
    Jun 2009
    Posts
    272

    Unanswered: How do we set a Global registry

    How do we set a global registry variable in db2.

    I know we can set instance level registry by issuing the below command
    eg: db2set DB2COMM=tcpip

    I want to set this parameter globally how do we do that?

    I tried doing db2set -g DB2COMM=tcpip, it errors out.

  2. #2
    Join Date
    Apr 2006
    Location
    Belgium
    Posts
    2,514
    Provided Answers: 11
    could you publish the error - was it executed by instance owner ?
    Best Regards, Guy Przytula
    Database Software Consultant
    Good DBAs are not formed in a week or a month. They are created little by little, day by day. Protracted and patient effort is needed to develop good DBAs.
    Spoon feeding : To treat (another) in a way that discourages independent thought or action, as by overindulgence.
    DB2 UDB LUW Certified V7-V8-V9-V9.7-V10.1-V10.5 DB Admin - Advanced DBA -Dprop..
    Information Server Datastage Certified
    http://www.infocura.be

  3. #3
    Join Date
    Jun 2009
    Posts
    272
    SQL 1042C system error

  4. #4
    Join Date
    Apr 2008
    Posts
    39
    Exaplanation of this error is as mentioned below. Please check that out. Please also let us know if somthing changed in recent with your db2 setup like new fix pack installetion etc.. what is the dblevel of your installed db2 ?


    A system error occurred. Some possible reasons for this error are:

    The database manager is not installed correctly or the environment is not set up correctly.
    On UNIX-based systems, db2iupdt may need to be run in order to update the DB2 instance to enable acquisition of a new system configuration or access to function associated with the installation or removal of certain product options, FixPaks, or modification levels.
    You might get this message if you are not using the correct DB2 Administration Server password.
    The command cannot be processed.

    User response
    To update the instance to acquire a configuration or access to function run DB2IUPDT <InstName>.
    If the error occurred while trying to connect to a database, get a trace (instructions below) and call IBM support.



    Thanks
    Naval K

  5. #5
    Join Date
    Jun 2003
    Location
    Toronto, Canada
    Posts
    5,516
    Provided Answers: 1
    Quote Originally Posted by blazer789 View Post
    SQL 1042C system error
    I thought you'd been on this forum long enough to figure out that you'd need to start by looking at db2diag.log...

  6. #6
    Join Date
    Aug 2008
    Location
    Toronto, Canada
    Posts
    2,367
    Try using root

    "root authority to set variables in the global-level registry" :
    IBM DB2 9.7 for Linux, UNIX and Windows Information Center

  7. #7
    Join Date
    Sep 2008
    Location
    Toronto,Canada
    Posts
    655
    Tried and found working as below

    Logged as root. Loaded db2profile. Then it works as db2set -g DB2COMM=TCPIP

    Seems that db2inst1 user does not have os privileges neede to change the registry.

    Regards

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •