On our test instance we have recently applied many patches however this has now caused a large number of Invalids the we are unable to compile manually or with ultpr.sql or adadmin. The dependencies are no longer being declared and I really want to avoid another clone in which we would have to reapply all the patches again anyway. Is there a way to tell when a package became invalid that i may cross reference this against the patch application dates?