Results 1 to 3 of 3
  1. #1
    Join Date
    Sep 2011
    Posts
    2

    Unanswered: Help with OEM backups failing - initialization error

    Hello Community. I am seeking help completing fully functional installation of Enterprise Manager. It will do everything except process backups either through Jobs or Scheduled Backups.

    Information follows:

    Please help if you can. I have read all installation and configuration manuals, operations manuals, each community entry on this and other Oracle forums, as well as sought help through various searches and independent publications on EM.

    Windows Server 2003 R2
    Standard x64 Edition SP2
    Windows NT OS
    VMware
    Oracle Standard Edition Database
    Oracle Database 11g Release 11.2.0.2.0 - 64bit Production
    PL/SQL Release 11.2.0.2.0 - Production
    CORE 11.2.0.2.0 Production
    TNS for 64-bit Windows: Version 11.2.0.2.0 - Production
    NLSRTL Version 11.2.0.2.0 - Production

    DHCP enabled…………… NO
    Installed EM Control using emca.

    Everything seems to be working except scheduling backups. Going through Availability>Scheduling Backups or through the Job scheduler, the job can be successfully submitted.

    View Job shows initialization error. In the Backup scheduler, testing the backup comes back successful and indeed places a backup in the archives.

    Prebackup Succeeds
    Backup Step shows: Malformed PDP Data

    Emagent.trc shows: error EMsdk.XML: ParseError: File=Stream, line=1, Mgs=Missing Value for USERNAME in RemoteOperationReq[]

    Emagent.log shows: error EMsdk.XML: ParseError: File=Stream, line=1, Mgs=Missing Value for USERNAME in RemoteOperationReq(01006)[]

    Emoms.trc shows: Timestamp, 594 [EMUI_16_44_04_/console/backup/] Error em.jobs remoteOp.2402 – DBVerify.remote{}: CommException: Internal error occurred.

    Emoms.log: Timestamp, 594 [EMUI_16_44_04_/console/backup/] Error em.jobs remoteOp.2402 – DBVerify.remote{}: CommException: Internal error occurred.
    At oracle.jdbc.driver.SQLStateMapping.newSQLException (Database Error.java:73)
    At oracle.jdbc.driver.SQLStateMapping.newSQLException (Database Error.java:111)
    At oracle.jdbc.driver.T4CTTIoer.processerror(T4CTTIoe r.java:472)
    At oracle.jdbc.driver. T4CTTIoer.processerror(T4CTTIoer.java:422)
    **((When searching for help on these java errors, plenty is found concerning outside applications, but nothing on em, and I am unable to apply outside answers to our situation (Mapviewer, Hyperion Essebase, etc)))


    Emagent_perl.trc shows: No entry for current date, but for the previous date::
    pwdexpiry.pl: Timestamp: warn: pwdexpiry: Invalid number of arguments passed
    And: pwdexpiry.pl: Timestamp: warn: pwdexpiry: Number of args is 1

    Emdb.nohup shows nothing that looks like errors other than possibly:
    IntializeStreamStatus : proc count = 0

    All Preferred Credentials are set up.

    Thank you in advance for any help you may offer.

  2. #2
    Join Date
    Mar 2010
    Location
    Vienna, Austria
    Posts
    149
    Hi,

    since you are on Windows:

    There should be a service called

    OracleJobScheduler<instance_name>
    This is responsible for scheduling jobs. Is this service startet ?
    "There is always an easy solution to every problem - neat, plausible, and wrong."
    -- H.L. Mencken

  3. #3
    Join Date
    Sep 2011
    Posts
    2

    slight delay

    Called away on another project for a wee bit. Now back on this project. Yes, the service is there and is running and is automatic.

    Went through stop dbconsole, reset all salient passwords, came back to backup issue and it is the same.

    Malformed PDP data. On a scheduled backup.

    Runs one time only backups fine. RMAN is set up independently and is doing the work, but i would like to schedule the dailies through oem.

    Thank you for any and all time and help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •