Results 1 to 3 of 3
  1. #1
    Join Date
    Oct 2011

    Unanswered: No data on reports

    Im new at Crystal reports, so i'm not sure where i may be going wrong.

    I'm connected to a database using a faircom ODBC driver provided by the software people.

    I created a new report in CrystalReports, was able to access the database using an ODBC (RDO) connection and it works fine, however the connection is showing "disconnected" when i check the Database Expert. In my reports field explorer i see the databse, tables and field. I inserted 2 field, clicked on PRINT to double check the data was coming through and all went well. I made no changes, just continued to add fields into my report.
    When i was finished adding fields, i went to PREVIEW the report and all that displayed was the headers.
    I went to REPORT, then REFRESH report data and i received no errors. I ran a dependency checker and again, no errors.

    I right click on the field and select Browse Data, and i can see the data.

    Any ideas where i could have gone wrong?

  2. #2
    Join Date
    Oct 2010
    If you right click on the report fields, select Browse Data and can see the data, then this confirms there is data coming to the report. The problem then could be the report or report fields itself.

    This would be a little hard to debug without the report itself, I suggest going through the entire report to see what you might have done wrong.

    If you prefer, you may attached your report here for someone to analyze the issue. You should use fictitious data for your test data and most important, you should "Save Data with Report" so that the person can debug the report with the exact circumstances/data on the report.

  3. #3
    Join Date
    Oct 2011

    Thumbs up no data

    When I right click on the field report, I CAN see the data . . . . so i started going field by field and working backwards......

    turns out a field i inserted, into the same column as other fields from a different table (same database) caused the report to fail. I cleared out the field and can finally get a full report.

    I added the field to it's own column, but still no joy. Any idea why a field from a separate table would cause the report to not work?


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts