Results 1 to 3 of 3
  1. #1
    Join Date
    Jul 2011
    Posts
    9

    Unanswered: CCSID integer Issue

    Hi experts,

    We have db2 9.1 on z/os mainframe and plan to make a copy of its database to a db2 9.7 running on a linux server. The problem is all tables have some fields defined as "FOR BIT DATA" and the CAST command in SELECT statements does not accept integer values on db2 9.7. We need to cast hex-value data of such tables to 1252 codepage which is not possible by the following command:

    CAST(c.CITYNAME as varchar(30) ccsid 1252)

    It only takes UNICODE and ASCII which does not return proper characters.

    Any resolution would be highly appreciative.
    Thanks

  2. #2
    Join Date
    Sep 2004
    Location
    Belgium
    Posts
    1,126
    Just an idea...
    Did you try to create a table on z/OS with a CCSID 1252 column?

    Yet a better idea would of course be to convert the "bit data" stuff on z/OS to an UTF-8 column on z/OS and then use "normal" transfer methods (DB2 Connect) to transparently do the conversion to the codepage used by the (Windows) client.
    --_Peter Vanroose,
    __IBM Certified Database Administrator, DB2 9 for z/OS
    __IBM Certified Application Developer
    __ABIS Training and Consulting
    __http://www.abis.be/

  3. #3
    Join Date
    May 2003
    Location
    USA
    Posts
    5,737
    If you use DB2 Connect to access the z/OS database from the Linux machine, you should be able to run the export command against the z/OS table, and it will be in DB2 LUW format. You may have to specify the code page on the export command as an option (see Export command in the DB2 LUW Command Reference manual). You will probably have to do a remote bind of utilities from Linux to the z/OS database using an Id that has sysadm on DB2 z/OS.
    M. A. Feldman
    IBM Certified DBA on DB2 for Linux, UNIX, and Windows
    IBM Certified DBA on DB2 for z/OS and OS/390

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •