Results 1 to 5 of 5
  1. #1
    Join Date
    Oct 2011
    Posts
    71

    Unanswered: Print Preview Freezeing on load with filter

    Morning, I have run into a snag on all of my reports. I've scoured the internet, but there is very little on this issue and no resolutions that I have found. I am attempting to start locking down my database, though I have no decided how far. I have been testing a Print Preview button on my reports.

    The button itself works fine, until the report is filtered. Once the filter is activate on a report and I use my print preview button, the report goes into print preview, however I am unable to click anything on access. Anything = Anything, no tool bars, buttons, scroll bars or anything else. However if i tab out of access and tab back into it, it works perfectly fine.

    If I toggle the filter off before I click on my print preview button it works.

    DoCmd****nCommand acCmdPrintPreview

    That is my only line of code and its on the Click Event of the button.

    I appreciate any ideas and your time in reading over this. Thanks!

  2. #2
    Join Date
    Mar 2009
    Posts
    5,442
    Provided Answers: 14
    ... works fine, until the report is filtered...
    How do you filter the report?
    Have a nice day!

  3. #3
    Join Date
    Oct 2011
    Posts
    71
    My primary coures for filtering is by passing paramters from a form. However, even if I hardcode the filters into the report, or type filters in after it loads it does the same thing.

  4. #4
    Join Date
    Mar 2009
    Posts
    5,442
    Provided Answers: 14
    Code:
    DoCmd****nCommand acCmdPrintPreview
    That is my only line of code and its on the Click Event of the button.
    I don't see any parameter passing in that code.
    Have a nice day!

  5. #5
    Join Date
    Oct 2011
    Posts
    71
    you are correct. the docmd. runcommand accmdprintpreview is a button on the report. I apologize for not being specific enough in my first post. However, since it is a button on the report, the report has already been generated. The paramater passing has already been completed.

    The workflow.
    I have a report selecter/filter form. If they only want the report to run from dates a to c then they'll put it on the form, select the report they want to run and then hit a button to create the report. This is where the paramater passing is done.

    At this point the report comes up. I have created 3 buttons on the report which is only see on report view. A Print Preview button, a print button and a close button.

    If i change the view by right clicking on the report it will change to print preview with no problems. However, using my button to change the report presents the problem explained earlier.

    Incase the question comes up. The basic way I filter is something like this:

    Docmd.OpenReport (variable01),acViewReport, , (Variable02)

    Variable 01 is dependent upon what report they select

    Variable 02 is dependent upon what paramaters they want to search by. If all boxes are blank, then the query is blank. If there is an ID number then it passes that through.

    The variables are created by If statements only way I know how to do it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •