Results 1 to 2 of 2
  1. #1
    Join Date
    Dec 2011
    Posts
    1

    Unanswered: Database does not exists in local database directory

    Hi,
    I tried to restore a db backup and after restoring when i try to connect to it I get error "SQL1013N The database alias name or database name "TPTOOLM" could not be found. SQLSTATE=42705

    I ran command db2 list db directory and got its entry in System Database directory : Database alias = TPTOOLM
    Database name = TPTOOLM
    Local database directory = /home/db2inst1
    Database release level = d.00
    Comment =
    Directory entry type = Indirect
    Catalog database partition number = 0
    Alternate server hostname =
    Alternate server port number =

    But when I run list db directory on <db path> to get the local db directory content I dont get the entry of TPTOOLM db

    Please suggest what shall I do to resolve this. Thanks!
    Last edited by Roopam; 12-29-11 at 02:42.

  2. #2
    Join Date
    Apr 2006
    Location
    Belgium
    Posts
    2,514
    Provided Answers: 11
    i would try uncatalog db xx
    list db directory on path
    catalog db on path to bring it back
    if not present with second command - try drop-uncatalog-restore
    Best Regards, Guy Przytula
    Database Software Consultant
    Good DBAs are not formed in a week or a month. They are created little by little, day by day. Protracted and patient effort is needed to develop good DBAs.
    Spoon feeding : To treat (another) in a way that discourages independent thought or action, as by overindulgence.
    DB2 UDB LUW Certified V7-V8-V9-V9.7-V10.1-V10.5 DB Admin - Advanced DBA -Dprop..
    Information Server Datastage Certified
    http://www.infocura.be

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •