Results 1 to 6 of 6
  1. #1
    Join Date
    Mar 2012
    Posts
    4

    Unanswered: Error while launching command

    Hello

    I am using Telelogic Synergy 6.5 and Informix DB.

    During the ccmdb update_statistics <database_path>, im getting the below error

    Updating statistics ...
    ERROR: Unknown error message number '-252'

    Function: dbu_exec
    INFORMIX: -252, ISAM: -105

    ERROR: Failed to update statistics on INFORMIX database

    Kindly help me in this regard.

    Thanks

    Regards
    Dominic J

  2. #2
    Join Date
    Sep 2011
    Location
    Pont l'Abbé, Brittany, France
    Posts
    381
    Provided Answers: 1
    Hi,

    you probably have a corrupt index. Can you please give more details on which Informix product you are using and which version ?

  3. #3
    Join Date
    Mar 2012
    Posts
    4
    Im not sure how to figure out the informix version.

    could you help me find out the version please.

  4. #4
    Join Date
    Sep 2011
    Location
    Pont l'Abbé, Brittany, France
    Posts
    381
    Provided Answers: 1
    login to the server as informix, and run at the prompt
    dbaccess -V

    You may need to run an environment setting script before

  5. #5
    Join Date
    Mar 2012
    Posts
    4
    I am unable to retrieve any version after trying what you stated.

    I re-created the whole informix db and unpacked the related dump which went fine.

    but now i am unable to connect to the telelogic server via a client, get the below error

    Warning: Informix: Ń╢
    (Function dbs_open, Informix -23197, ISAM 0).
    Warning: Telelogic Synergy startup failed.

    I tried a ccmdb check <database_path> -d and there were no inconsistencies with the DB.

    but with a ccmdb check <database_path> -c there are a few inconsistencies which i'm not aware of what needs to be done

    Im scared to do a ccmdb repair as if there are any errors it will delete the DB and i will have to import the dump once again.

    Please do help!!!!!

    Thanks

  6. #6
    Join Date
    Sep 2011
    Location
    Pont l'Abbé, Brittany, France
    Posts
    381
    Provided Answers: 1
    I do not know those commands. They are not Informix commands.
    Error -23197 shows a problem of character set: the character set of your database does not matches the one set in your environment variable DB_LOCALE.

    what are those inconsistencies?

    in any case, before running anything, make a backup copy of your db, but I think your problem is more an env var misconfiguration...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •