Results 1 to 2 of 2
  1. #1
    Join Date
    Mar 2012
    Posts
    1

    Only showing first record on table

    Alright, so here's the problem and for the life of me I can't figure it out:

    Task: Creating a report that lists all of our medically disabled employees. Must be a single line report (i.e. can not group and then list underneath).

    Problem:
    Some employees have more than one disability. This causes them to appear multiple times on the single-line report.

    This is the table inside of my program that I am pulling from. This table is for a single employee. Notice how more than one disability is listed:
    (See bardistable.jpg below)

    This is the results of my report when I run it in Crystal:
    (See reportresults.jpg below)

    Somehow, I need to figure out a way to only show the first disability an employee has listed on their table. Like in employee 0077's case, I only want to see disability D02... not D04 and D05 too.

    I DID find a solution to this by way of Section Expert > Suppress (No Drill-Down) > previous({hrpersnl.p_empno})={hrpersnl.p_empno}. But I can not use this formula because it causes my first employee to be suppressed for some reason.

    Help please?
    Attached Thumbnails Attached Thumbnails bardistable.JPG   reportresults.JPG  

  2. #2
    Join Date
    Mar 2012
    Posts
    12
    Quote Originally Posted by Betsbabe View Post
    Task: Creating a report that lists all of our medically disabled employees. Must be a single line report (i.e. can not group and then list underneath).

    Problem:
    Some employees have more than one disability. This causes them to appear multiple times on the single-line report.
    From the menubar, choose Report > Group Expert and group by EmpNumber.

    Go to Design Mode, grab the "Group #1 Name" (which should be in the Group Header #1), and pull it down to the Group Footer #1. Then grab the Disability Type which is in the Details section and drag it down to the Group Footer #1.

    Right click on the Details item on the left and change it to "Suppress (No Drill-Down)". You'll probably want to do a little formatting changes, such as changing the "Group #1 Name" from boldface to lightface, but this should provide the output needed.

    I would undo the effort taken with the Section Expert and return it to its default setting. HTH.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •