Results 1 to 4 of 4
  1. #1
    Join Date
    Feb 2012
    Posts
    26

    Unanswered: Oracle Export Import Utility Different Versions

    We are migrating
    from [IBM P5 - AIX 5.3 - Oracle DB 10.2.0.1 64bit]
    to [IBM P7 - AIX 6.1 - Oracle DB 10.2.0.5 64bit]

    The new database is already up and running, our next step now is the following:
    1. Create Tablespaces (done)
    2. Export the Database from P5
    3. Import the dump to P7.

    We have this following options:

    I. Use a Windows XP workstation 32bit with Oracle 10.2.0.1 Database software to export from P5, then import the dump to P7. (Export/Import Utility 10.2.0.1 Windows 32bit)

    II. Use the Export Utility of the P7 (10.2.0.5 AIX 64bit) to do the export and import.

    III. Use the Export Utility of P5 (10.2.0.1 AIX 64bit) then use the Import Utility of P7 (10.2.0.5 AIX 64bit)

    Can someone give me an advice what to do? And what problem might I encounter?

    BTW, our colleague tried to do the following:
    A. Use Windows - Export Utility 10.1.0.2.0 - 32bit to make a dump of our database (Oracle 10.2.0.1.0 AIX 64bit)
    B. Use Windows - Import Utility 10.1.0.2.0 - 32bit to import the dump file from step A to our new database (Oracle 10.2.0.1.0 AIX 64bit)

    But after issuing
    imp system/password@NEWDB file=(a.dmp, b.dmp... c.dmp) full=y ignore=y statistics=none

    The import seems to hang here...
    importing SYSTEM's objects into SYSTEM

  2. #2
    Join Date
    Nov 2003
    Posts
    2,935
    Provided Answers: 12
    exp/imp is deprecated. Use expdp and impdp instead.

    They are much more flexible and faster as well

  3. #3
    Join Date
    Oct 2002
    Location
    Cape Town, South Africa
    Posts
    253
    You can use any of I, II or III and you won't have any problem with doing the imp/exp the way you are saying. I do it every day. @shammat's option will probably be faster, but I've never tried it.

    The real answer though is to do a proper RMAN backup of your P5 and do a proper RMAN restore on your P7. This option is the fastest, the most accurate, and will test your disaster recovery procedure all in one.

    The problem you colleague had was due to the use of imp 10.1 against Oracle 10.2 db. That is a known issue. But there is a work around...
    # Always export 10.1 database using 10.1 exp utility
    # Always export 10.2 database using 10.2 exp utility
    # Always import 10.1 database using 10.1 imp utility
    # Always import 10.2 database using 10.2 imp utility
    It does not matter what version the dump file came from, just as long as you use the exp/imp utility that is compatible with the database being connected to.

  4. #4
    Join Date
    Oct 2002
    Location
    Cape Town, South Africa
    Posts
    253
    @Rektanocrit- Sorry, I did not see that before, but you are trying to imp/exp the entire db including the system account?
    If so, then IMP/EXP are definitely 100% out. Not a good idea at all.
    In this case I would say that the only answer is RMAN backup and restore. If you are not familiar with it, then you need to get familiar fast (or back away from the keyboard).
    I don't know why but many seem to be afraid of RMAN and refuse to use it. But it's actually really easy to use.
    Backup the database
    Restore the database
    Further reading:Oracle® Database Backup and Recovery Basics

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •