Results 1 to 4 of 4
  1. #1
    Join Date
    May 2002
    Posts
    157

    Unanswered: missing or broken reference to the file ꞌMSCAL.OCXꞌ

    I have a database that works perfectly with 2000, 2003 and 2007 but when I try to open it on 2010 I get the following error message.

    "Your Microsoft Office Access database or project contains a missing or broken reference to the file ꞌMSCAL.OCXꞌ."

    Thanks to Allen Brown I had entered the following into my 2007 and earlier databases. Allan’s web page is saying this should work in 2010
    'Copyright: Allen Browne's Database And Training, 2007.
    'Author: Allen Browne. allen@allenbrowne.com
    Microsoft Access tips: Popup Calendar

    * Note the 'IF' statement (in the client details form) has been entered by me to allow one calendar to update two text boxes.

    Can anyone tell me what is wrong and how to fix this?
    If possible I would like to use the same coding for my 2007 and 2010 or later versions. If this is impossible to do can you please advise.

    I really like Allen's calendar design (see Microsoft Access tips: Popup Calendar) so any advise would be gratefully received.


    There is too much coding to put into this thread, so please see document attached.
    Attached Files Attached Files

  2. #2
    Join Date
    Nov 2004
    Location
    out on a limb
    Posts
    13,692
    Provided Answers: 59
    from the URL you linked to
    In Access 2007 and laber, there's a popup calendar built in, so this form is not needed (though it does work.) Just set the Show Date Picker property of the text box to "For dates."
    I'd rather be riding on the Tiger 800 or the Norton

  3. #3
    Join Date
    May 2002
    Posts
    157
    Hi thanks,

    but the Show Date Picker property of the text box is already set to "For dates."

    and I still get the error message on 2010

  4. #4
    Join Date
    Nov 2004
    Location
    out on a limb
    Posts
    13,692
    Provided Answers: 59
    tht error message usually indiactes a problem with the referencesd for this installation. either the installation diodnt' complete or its been dicked around with.
    check the refercnes in a VB window to make certain the relevant Occie/Access library is checked
    I'd rather be riding on the Tiger 800 or the Norton

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •