Results 1 to 6 of 6

Thread: HACMP issue

  1. #1
    Join Date
    Sep 2006
    Posts
    97

    Red face Unanswered: HACMP issue

    I installed on two servers and user and its group was created on both servers.

    Once instance was created

    I modified db2node.cfg file with HAname
    And created .rhosts file in instance home directory and add + Instance_name

    Db2stop and start commands are failing.

    if modify the db2node.cfg file with current hostname . Everthing is working fine.

    i verified /etc/services/ , /etc/hosts, .rhosts.

    I am getting
    db2stop
    08/23/2012 14:54:31 0 0 SQL6048N A communication error occurred during START or STOP DATABASE MANAGER processing.
    SQL1025N The database manager was not stopped because databases are still active.

  2. #2
    Join Date
    Sep 2006
    Posts
    97
    Can Some body can help me out here.

    Db2 9.1 FP 5 Aix 5.3

  3. #3
    Join Date
    Aug 2008
    Location
    Toronto, Canada
    Posts
    2,367
    Some people use an alias in /etc/hosts. See p.298 here:
    http://www.redbooks.ibm.com/redbooks/pdfs/sg247363.pdf

  4. #4
    Join Date
    Sep 2006
    Posts
    97
    DB2girl,


    Thanks for reply.

    Verified, that No issues there. I build so far 15 HACMP hosts in my career, I am really doing something very stupid. That's why i can't figure this one out.

    Will rebuild everthing again. This time with little bit caustious.

  5. #5
    Join Date
    Aug 2008
    Location
    Toronto, Canada
    Posts
    2,367
    Verify that "the hosts entry in the /etc/netsvc.conf file must contain local as the first parameter" on both servers.

  6. #6
    Join Date
    Sep 2006
    Posts
    97

    HACMP issue

    Found the problem. Unix team didn't turn on Rhost (rlogin) ports.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •