Results 1 to 2 of 2
  1. #1
    Join Date
    Apr 2012
    Posts
    1

    Red face Unanswered: Connection from Solaris to Windows :Client host or user is not trusted by the server.

    Hi all,
    I need your help to resolve my problem in connection of Informix from Solaris to Windows.
    I've installed Informix DS 11.7 on two system:
    - One on Windows, I created a DB instance with server name as ol_informix1170, user name: informix, password : Ifmpass2
    I've created my own database name as "test"
    I can access to the "test" database properly by using command:
    dbaccess test
    - One on Solaris, I want to use it as a client to access to DB server installed on Windows, so I don't create DB instance on this system. I create user name informix with the same password with windows (pw: Ifmpass2).
    I configured the sqlhosts as below:
    ol_informix1170 olsoctcp <windows_hostname> 9088
    I add above port into /etc/services already:
    ol_informix1170 9088/tcp
    The ownership of all contents in INFORMIXDIR is informix user.
    When I just type "dbaccess" then select server "ol_informix1170" -> database "test"-> input user name & passwd, the connection to Windows server made properly.
    But when I typed "dbaccess test", an error occurs in online log:

    04:46:02 listener-thread: err = -956: oserr = 0: errstr = root@<hostname>.<domain>[hostname]: Client host or user root@<hostname>.<domain>[hostname] is not trusted by the server.

    I have tried some way such as add the <hostname> into hosts.equiv or .rhost on Windows but the issue is still not fixed.
    Do I need to restart what service on Windows to make the setting in hosts.equiv or .rhost take affect?
    Do I miss something in configuration?

    Thanks,
    Suru

  2. #2
    Join Date
    Sep 2011
    Location
    Pont l'Abbé, Brittany, France
    Posts
    381
    Provided Answers: 1
    Hi,

    this part is not very funny, but I think that in the sqlhost file, you must write the host name exacty as the 'hostname' output (ex: myserver.domain)
    same comment for the hosts.equiv file.

    as per the connection from windows, did you use the setnet32 command to set it ?

    Also don't forget to check that the ports are not blocked by the firewall on both sides...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •