Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2012
    Posts
    1

    Unanswered: Errors in log ECF=0x900001C0=-1879047744=ECF_GENREG_OPEN_OUTPUT_FILE_FAILED Failed to

    The db2diag.log for my db2 database on the primary node is full of errors (see below ).

    2012-08-29-09.51.56.301783+720 I542338A1190 LEVEL: Error
    PID : 2079 TID : 2199282411856PROC : db2acd 0
    INSTANCE: db2inst3 NODE : 000
    FUNCTION: DB2 Common, Generic Registry, GenRegFile::OpenReg, probe:8
    MESSAGE : ECF=0x900001C0=-1879047744=ECF_GENREG_OPEN_OUTPUT_FILE_FAILED
    Failed to open the output registry
    CALLED : OS, -, fopen
    RETCODE : ECF=0x90000513=-1879046893=ECF_GENREG_REGISTRY_DOESNT_EXIST
    The registry does not exist.
    DATA #1 : String, 27 bytes
    /bnz/db2as/das/cfg/dassystm
    CALLSTCK:
    [0] 0x00000200018EC142 /home/db2inst3/sqllib/lib64/libdb2osse.so.1 + 0x1C0142
    [1] 0x00000200018ECED2 ossLogRC + 0x102
    [2] 0x00000200025D7E8E _ZN10GenRegFile7OpenRegEm + 0x236
    [3] 0x00000200025E85AA _ZN9GenRegBin3GetEmPvS0_ + 0xFA
    [4] 0x0000020005A18AE8 _Z20db2dasConfigGetParamP19db2dasConfigContextP11d asCfgParam + 0xEC
    [5] 0x0000020005A1AE12 _Z20db2dasReadConfigFileP11dasCfgParamm + 0xFE
    [6] 0x0000020005A1B094 readLocalDasCfg + 0x38
    [7] 0x0000020005A1B288 db2DasCfgGet + 0x15C
    [8] 0x0000020004EFB3CC _ZN13hiAlertCfgMgr7refreshEb + 0x1E4
    [9] 0x0000020004EE8EC0 _ZN15hiDataCollector17updateRefreshSetsEv + 0x150
    ~

    Cant figure out what causing this .

    the output for db2leve is as follows :

    db2level
    DB21085I Instance "xxxxxxx" uses "64" bits and DB2 code release "SQL09072"
    with level identifier "08030107".
    Informational tokens are "DB2 v9.7.0.2", "special_26416", "IP23091_26416", and
    Fix Pack "2".
    Product is installed at "/xxx/opt/IBM/db2/V9.7FP2".

    any assistance on this is highly appreciated.

  2. #2
    Join Date
    Jun 2003
    Location
    Toronto, Canada
    Posts
    5,516
    Provided Answers: 1
    Quote Originally Posted by Sail_96 View Post
    Cant figure out what causing this .
    Code:
    The registry does not exist.
    DATA #1 : String, 27 bytes
    /bnz/db2as/das/cfg/dassystm
    ---
    "It does not work" is not a valid problem statement.

  3. #3
    Join Date
    Aug 2008
    Location
    Toronto, Canada
    Posts
    2,367
    Try to update DAS using dasupdt. Or remove DAS if it's not needed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •