Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2012
    Posts
    2

    Unanswered: Forms 10g Details records going awol

    Hi everyone,

    I am having an issue with a multi block form (10.1.2.3). There is one master/header table (Block A) that has a detail block (Block B). That detail block is in turn master to another (Block C) detail block. This was built by using the data block wizard to handle the fields, relationships, etc.

    My issue is that when I run a query everything looks great - there's data in all 3 blocks. But if I click into the middle block or Block B I have problems with data disappearing. If I click in line one of block B nothing happens and everything works great, however if I click anywhere else (line 2, 5, etc) then all the data disappears. I believe it's being thrown back into query mode. All I have to do to repopulate the data on-screen is re-execute the query and make sure to click in line 1 of block b.

    This has been driving me crazy to fix and am running out of ideas. Has anyone else run up against this?

  2. #2
    Join Date
    Aug 2012
    Posts
    2
    I should add that I can find no traceable code instance that is specifically calling ENTER_QUERY.

  3. #3
    Join Date
    Jan 2004
    Location
    Croatia, Europe
    Posts
    4,094
    Provided Answers: 4
    Are there any block-level triggers on block B? What do they do?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •