Results 1 to 7 of 7
  1. #1
    Join Date
    Sep 2012
    Posts
    3

    Unanswered: Web site delay on load

    Hello,

    My Wordpress sites like this one have a delay of about 15 seconds before loading.

    I suspect this might be related to MySQL or PHP config.

    For MySQL, I tried adding skip-name-resolve.

    For PHP, I tried changing localhost to 127.0.0.1 at PHP MySQL settings.

    Both didn't help. Does anyone have any other ideas?

    Thanks

  2. #2
    Join Date
    Sep 2009
    Location
    San Sebastian, Spain
    Posts
    880
    Try using Wordpress caching. This attempts to convert the pages from being dynamic to being static and storing them in a cache. This reduces processing of PHP pages and accessing the database.

    If this still does not give the performance you are looking for talk with your hosting provider to see how much traffic is being processed by your host. Typically a host will have many web servers running off a single host and you are sharing with all of them. So if you have only a few requests, it might be that others have 1,000's and this will affect your overall performance.
    Ronan Cashell
    Certified Oracle DBA/Certified MySQL Expert (DBA & Cluster DBA)
    http://www.it-iss.com
    Follow me on Twitter

  3. #3
    Join Date
    Sep 2012
    Posts
    3
    thanks for your answer. but this doesn't have anything to do with caching, I tried it before.

    there is a 15 seconds delay before the site opens, there is definitely a problem somewhere.

    I'm on a dedicated 1gb VM Linux. But I set it myself, so maybe I misconfigured something.

    thanks

  4. #4
    Join Date
    Nov 2004
    Location
    out on a limb
    Posts
    13,692
    Provided Answers: 59
    id try to get some metrics before trying to identify solutions
    you say there is a 15 second delay before the page loads. you need to identify where that time is going
    build a variable that records the timestamps before each significant statement. then display the variabel and work out where the time is being consumed

    In these modern time a 1GB system memory seems very low
    I'd rather be riding on the Tiger 800 or the Norton

  5. #5
    Join Date
    Sep 2012
    Posts
    5
    Maybe you should test your ping, it could just be a delay depending on your traffic.

  6. #6
    Join Date
    Sep 2012
    Posts
    3
    I have enabled slow log and now it is full of this line:

    SELECT option_name, option_value FROM wp_options WHERE autoload = 'yes';

    I have optimized "options" table, removed unnecessary entries. but still getting this one.

    does anyone have an idea about this?

    thanks

  7. #7
    Join Date
    Mar 2004
    Posts
    480
    Do you have an index on the autoload column?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •