Dear all,

I am in the process of upgrading postgreSQL DB from version 7.3,
and I have been experiencing some problems.

I started with pg_dump, and it finished without error messages, but
the data in some of the tables in the DB was not copied (only the table
and index definition).

The tables which were not copied were a mix of small and large
tables. Trying pg_dump -t with individual tables didn't make a
difference. I tried COPY or \copy from the psql prompt but the
command generates an empty file, although the table is not
empty. There is no error message either. The server just echoes COPY.

To save the data in these tables, I tried instead:
psql -qc 'select * from table' dbname > filename

It worked for some of the tables which were not copied during dump, but
it failed on the very large tables.

For these tables, the process either ended with segmentation fault,
or with an error message:

server sent data ("D" message) without prior row description ("T" message)

I found a posting in one of the forums saying that such error messages
could be the result of insufficient memory:

"Before 7.4, the client-side libpq library tended to go nuts like this
if the received query result overran available memory."

I installed version 7.4.30, but I cannot start the server, because the data is
not compatible. So I am stuck with version 7.3.

How do I get around this problem and save the data in the large tables?

The host operating system is linux RHEL 3

Thank you
-Jona