Page 1 of 3 123 LastLast
Results 1 to 15 of 37
  1. #1
    Join Date
    Aug 2012
    Posts
    70

    Unanswered: issue with db2inidb DBT1008N

    Hello dear all

    I have DB2 V9.1 FP 6a under AIX 5.
    I want to copy the three databases as of one instance on one server as snapshot in another instance on another server.

    The source databases have been first set in suspend IO and the mirror disks have been splitted. Then the databases have been set in resume IO and all datafiles, database directory, database local directory and logfiles have been copied from the mirror disks to tape.
    The backed up files have then been copied from tape to the destination server.
    I have create the config_files and tried to initialise the databases.
    The first one was fine, but the second database has some problem. Please see below the steps I performed and the error messages

    vwsacc9> db2inidb SCHWABNA as snapshot relocate using config_file_schwabna
    Relocating database...
    Files and control structures were changed successfully.
    Database was catalogued successfully.
    DBT1000I The tool completed successfully.
    Database relocation was successful.
    DBT1036N Unable to refresh the directory cache after a successful relocation of database "SCHWABNA". SQLCODE = "-1025".

    => According to the IBM documanetation I have to restart the command without relocate.

    vwsacc9> db2inidb SCHWABNA as snapshot
    DBT1011N Unable to restart database "SCHWABNA" with the WRITE RESUME option. SQLCODE = "-1042".

    vwsacc9> db2inidb SCHWABNA as snapshot
    DBT1008N Database "SCHWABNA" is not a split mirror image.


    Could someone explain me what happened? Whether I did a mistake during the initialisation or whether the backup is not correct?

    I would really appreciate if someone could give me a feeedbackup soon

    Thanks a lot in advance
    Best regards
    Renaud

  2. #2
    Join Date
    Jan 2003
    Posts
    4,292
    Provided Answers: 5
    Why not just do an online DB2 backup of each database to tape and then do a redirected restore on the new server?

    Andy

  3. #3
    Join Date
    Aug 2012
    Posts
    70
    A online backup has some impact on the performance of the batch processing running each night. So we decided to perform a shadow backup.
    The problem we have at the moment is that we need the backup taken on a certain day (9th september), and we can not run now an online backup of the database take on the 9th September. For the future we can think about online backup, but now we have an issue and I would like to know which step (backup or db2inidb) has not been correctly performed
    Thanks for your help
    Best regards
    Renaud

  4. #4
    Join Date
    Jun 2003
    Location
    Toronto, Canada
    Posts
    5,516
    Provided Answers: 1
    Did you try to bounce the instance and activate the relocated database after your first error (SQL1025N)? Seems pretty harmless to me.
    ---
    "It does not work" is not a valid problem statement.

  5. #5
    Join Date
    Jan 2003
    Posts
    4,292
    Provided Answers: 5
    When you split a mirror, you have to get it exactly correct for it to work properly. My guess is that you missed something in the backup of the mirror, or the mirror was done improperly.

    Andy

  6. #6
    Join Date
    Aug 2012
    Posts
    70
    Please apologise the delay of my reply, but I was sick last week (and I am still sick) ..
    Yes I agree with you, something may be wrong in the backup mirror, or may I did a mistake trying to reinitialise the database:
    I used the option "db2inidb ... snapshot..."
    For the second database I tried with
    "db2inidb ... mirror...." and it was fine. Except that I have now problems with missing logfiles. (see below)

    Do you have any idea?

    Thanks and regards
    Renaud

    vwsacc9> db2 rollforward db VWSABNA to end of logs and stop
    SQL4970N Roll-forward recovery on database "VWSABNA" cannot reach the
    specified stop point (end-of-log or point-in-time) because of missing or
    corrupted log file(s) on database partition(s) "0". Roll-forward recovery
    processing has halted on log file "S0003441.LOG".

  7. #7
    Join Date
    Jan 2003
    Posts
    4,292
    Provided Answers: 5
    Does the mirror have the exact filesystem layout as the source? Are the logs in the same location? Are the permissions correct?

    Andy

  8. #8
    Join Date
    Aug 2012
    Posts
    70
    I was sick the last 4 weeks and could not answer earlier. Please pologise for that.....
    I managed to restore the database, not with the mirror copy but using a online backup I have taken on the same day as emergency solution. I didn't want first to use the emergency solution, but I didn't have any other possibility.

    Now the databases are running fine but I am not able (allowed) to select from the view SYSIBMADM.SNAP*

    [IBM][CLI Driver][DB2/AIX64] SQL30082N Attempt to establish connection failed with security reason "" (""). SQLSTATE=08001

    Could someone give me an advice?

    Thanks a lot
    Renaud

  9. #9
    Join Date
    Jan 2003
    Posts
    4,292
    Provided Answers: 5
    Are you getting that error on the SELECT or CONNECT?

    Andy

  10. #10
    Join Date
    Aug 2012
    Posts
    70
    I can connect and select other tables and views (also syscat.*)
    But I cannot select a sysibmadm.snap% view :

    select * from SYSIBMADM.SNAPDB;
    [IBM][CLI Driver][DB2/AIX64] SQL30082N Attempt to establish connection failed with security reason "" (""). SQLSTATE=08001

    0 rows selected because of ERROR.

  11. #11
    Join Date
    Jan 2003
    Posts
    4,292
    Provided Answers: 5
    Try rebinding everything on the restored database and see if that fixes the problem.

    Andy

  12. #12
    Join Date
    Aug 2012
    Posts
    70
    I ran the command

    db2rbind <dbname> -l logfile all

    According to the logfile the rebind was successfull, but I stil cannot select the views

    Renaud

  13. #13
    Join Date
    Jan 2003
    Posts
    4,292
    Provided Answers: 5
    I believe that it is time to open a PMR with IBM.

    Andy

  14. #14
    Join Date
    Aug 2012
    Posts
    70
    Since all databases of the instance are affected, the issue may be related to the instance.
    As I first try to initialise the databases, I have copied the database directory and the local database directory from the source server to the destination server.
    As I perform the redirect restore, since the databases have been already created by the db2inidb command, I simply dropped them and started the redirect restore.
    Maybe there are some configuration parameters in the instance which I have to modify but I am not sure.
    If you don't see any oter possibility I will open a PMR
    Thank for your support

    Renaud

  15. #15
    Join Date
    Aug 2008
    Location
    Toronto, Canada
    Posts
    2,367
    Quote Originally Posted by Renaud_HLE View Post
    select * from SYSIBMADM.SNAPDB;
    [IBM][CLI Driver][DB2/AIX64] SQL30082N Attempt to establish connection failed with security reason "" (""). SQLSTATE=08001

    Need to know the RC for this error. Try executing this query from the server. If it fails, provide db2diag.log and the output from "db2 list db directory"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •