Results 1 to 3 of 3
  1. #1
    Join Date
    Oct 2012

    Unanswered: Access Via Roles In Database Vault

    Hoping someone can provide assistance please?

    I am trying to grant SELECT access to users via roles to tables in multiple schemas - all of which reside reside in the same realm in database vault.

    The tables' owner is a DB vault owner within the realm, and the users to which I am trying to grant access are participants in the same realm.

    When I GRANT SELECT privs directly on the table to the participant users, they can see it, however when I grant access via a role instead, these users are unable to see the table (error object does not exist).

    I have tried bringing the role into the realm but it is still not working.

    Has anyone had a similar issue or know what the solution is?
    I am assuming that I do not need to use Secure Roles in this instance?
    Last edited by jpslater; 10-07-12 at 15:28.

  2. #2
    Join Date
    Aug 2003
    Where the Surf Meets the Turf @Del Mar, CA
    Provided Answers: 1
    privileges acquired via ROLE do NOT apply within any named PL/SQL procedure
    & guess what Data Vault uses.
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

  3. #3
    Join Date
    Oct 2012
    Thanks anacedent.

    I realised that procedures do not respect roles - so are you saying that you cannot grant privileges via roles within the same data vault realm?

    If so - is there an alternative / workaround I should be looking into?
    Last edited by jpslater; 10-08-12 at 07:18.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts