I tried to install the mysql monitor, but stumbled on some problems.

Here is what I did.

1. Installed a second instance of mysql server on one of our servers into a different folder rather than into the regular folder because there is already another instance of mysql server running on the same server.
2. created the user service_manager user with a password.
3. The new instance runs on different socket, different port, different pid file and different binaries.
4. Now I switched to the regular env. and installed myql monitor.
5. Install had one error which is below.

Setup has completed installing the MySQL Enterprise Monitor files on your
computer (errors were found during the installation process).

No other error and no log files are created.
6. Started the mysql monitor. Here is what I found.

$ ./mysqlmonitorctl.sh status
MySQL Enterprise MySQL is not running
MySQL Enterprise Tomcat is not running
$ ./mysqlmonitorctl.sh start
Using CATALINA_BASE: /opt/app/mysql_mon/ent_mon/apache-tomcat
Using CATALINA_HOME: /opt/app/mysql_mon/ent_mon/apache-tomcat
Using CATALINA_TMPDIR: /opt/app/mysql_mon/ent_mon/apache-tomcat/temp
Using JRE_HOME: /opt/app/mysql_mon/ent_mon/java

$ ./mysqlmonitorctl.sh status
MySQL Enterprise MySQL is not running
MySQL Enterprise Tomcat is running

I believe mysql monitor is conflicting with the old instance of mysql server.

Did anyone come across this problem? I can't use the existing mysql server as the version is not compatible with mysql monitor requirements.

I tried even using the bundled mysql server option, but got the following error.

Warning: Problem running post-install step. Installation may not complete
Error running /opt/app/mysql_mon/source_files/
--defaults-file=/opt/app/mysql_mon/source_files/ /opt/app/mysql_mon/mysql/my.cnf

--user=mysql : ./bin/mysqld: Too many arguments (first extra is
Use --verbose --help to get a list of available options
121016 12:03:06 [ERROR] Aborting

Any help is appreciated.