Results 1 to 5 of 5
  1. #1
    Join Date
    Nov 2007
    Posts
    93

    Unanswered: create pdf issue with vba + report

    Hello

    I have the access report which is working fine when i view the report in report view ( shows as expected)

    but i usually export the report, saving the report in pdf format, it used to work fine in the past and now its actually creating the report and saving the report but some part of the report is showing as # error

    but when i view the report in report view its just fine and even when i right click on the report and if i try to manually create/print the report in pdf format, its just working fine but with the vba code its breaking

    if i debug the code its breaking at following line

    DoCmd.OutputTo acOutputReport, RptName, ".pdf", loc, False

    Could you please help me figure out why its breaking at the above code

    Thanks

  2. #2
    Join Date
    Nov 2004
    Location
    out on a limb
    Posts
    13,692
    Provided Answers: 59
    Any clue as to the error message?
    I'd rather be riding on the Tiger 800 or the Norton

  3. #3
    Join Date
    Nov 2007
    Posts
    93
    There is no error message its simply coming out of the loop with no error message

    its creating the pdf but with the # error thing in the exported report

    if i manually right click and print the report to adobe printer its just working fine

    i think something is wrong with Adobe pdf maker or the disteler but not sure

  4. #4
    Join Date
    Nov 2004
    Location
    out on a limb
    Posts
    13,692
    Provided Answers: 59
    this could be anyone of a number of things, but I suspect you may well be correct that its a problem with the PDF creator.
    is it the official Adobe PDF writer or one of the many clone packages
    it may be a problem with How Access writes to the PDF writer IE there is something in your report that the PDF writer doens't like.
    it could be a data issue, try regenerating the reprot with a very limited know data set and see if it works.
    I'd rather be riding on the Tiger 800 or the Norton

  5. #5
    Join Date
    Nov 2007
    Posts
    93
    its licensed version but the only change from last run to today is the change in user credentials ( different user)

    do we have any Library references that could have been removed ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •