Results 1 to 2 of 2
  1. #1
    Join Date
    Jun 2011
    Posts
    3

    Unanswered: cannot drop connection in ASE repserver(15.0.2)

    I am trying to drop one of the old databases which has warm standby replication to standby. I stopped rep agent on primary and standby, dropped connection to standby, and tried to dropped it to primary, but getting the error message that database has some replication definitions.


    1> drop connection to pr_extapp01.dyna
    2> .
    Msg 15038, Level 12, State 0:
    Server 'pr_rep_extapp':
    Database 'pr_extapp01.dyna' is the primary for some replication definitions. Cannot drop connection to it.
    1>


    I dropped all definitions with primary at pr_extapp01.dyna, and now when I ran "rs_helprep", it does not show any definitions on that database. However, I am still unable to drop the connection, it still complains. Have you ever seen anything like this?

  2. #2
    Join Date
    Oct 2012
    Posts
    8
    Try to reboot your server.

    After that drop the connection. You need to make sure there would not be any def and sub associated with it. Thanks,

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •