Hi all,

(previously posted on serverfault.com without response; I think posting it here may yield better results)
Note: I'm definitely not a Sybase guru, only interested to see if some programs I'm running work on the database (as well as others).

I've set up a single CPU Sybase ASE 15.7 test system on a Debian Squeeze x64 KVM virtual machine. I notice the CPU load goes to 100% and stays there.

Looking at Sybase docs it seems ASE detects the machine is idle and then takes over all processing just waiting for a connection (and if needed, doing some housekeeping apparently).

Normally that would be fine but as it is running in a VM it's taking away processor resources other VMs could use - and the increased fan noise of the PC near my desk annoy me.

I've tried to remedy this:

- set the "runnable process search count" parameter from DEFAULT (2000 IRC) to 3 in /opt/sybase/ASE-15_0/SYBASE.cfg

- from Part 4 - Configure Node: oralin11 - Sybase I added this to my /etc/init.d/sybase startup script: echo 0 > /proc/sys/kernel/randomize_va_space (though I don't think it'll make much difference)

How can I tell Sybase to "behave" and not hog the processor - I don't mind reduced performance at all. Of course, I'd be happy to generate config etc - but don't know what's relevant right now.

BTW:
1. while in theory I could look into running the kvm process for that machine under nice or some other such tool, I'm using the Proxmox management GUI to manage the VMs so I'd probably need to modify the Proxmox code.
2. alternatively I could rebuild the server on an OpenVZ container and try and limit CPU usage there, perhaps using User Beancounters.

Thanks!