Results 1 to 3 of 3
  1. #1
    Join Date
    Nov 2012
    Posts
    7

    Unanswered: express c and SSL

    Hello,
    I installed the express-c version of DB2 on a linux ubunto-10.04 machine.
    I was advised to do so using the "apt-get install" command.
    I am now trying to configure this machine to be able to work with the SSL protocol.
    I am trying to follow the steps written in the IBM website but i seem to stuck on the GSkit part.
    When i am using this command:
    sudo ./gsk8capicmd -keydb -create -db "sslserver.kdb" -pw "1234567" -stash

    I get the error:

    error while loading shared libraries: libgsk8km.so: cannot open shared object file: No such file or directory

    the GSkit folder exists but i can't find the libgsk8km.so file.
    What am i missing?
    What have i forgot to install?

  2. #2
    Join Date
    Apr 2006
    Location
    Belgium
    Posts
    2,514
    Provided Answers: 11
    Best Regards, Guy Przytula
    Database Software Consultant
    Good DBAs are not formed in a week or a month. They are created little by little, day by day. Protracted and patient effort is needed to develop good DBAs.
    Spoon feeding : To treat (another) in a way that discourages independent thought or action, as by overindulgence.
    DB2 UDB LUW Certified V7-V8-V9-V9.7-V10.1-V10.5 DB Admin - Advanced DBA -Dprop..
    Information Server Datastage Certified
    http://www.infocura.be

  3. #3
    Join Date
    Nov 2012
    Posts
    7

    Thanks for the help but

    I tried the suggestion in the link - meaning that i have the symbolic links required but still it insists returning the same error

    bla@bla:/opt/ibm/db2/V9.7/gskit/bin$ ls
    gsk8capicmd libgsk8cms.so libgsk8iccs.so libgsk8p11.so libgsk8valn.so
    gsk8ver libgsk8dbfl.so libgsk8km.so libgsk8ssl.so private_verifyinstall
    libgsk8acmeidup.so libgsk8drld.so libgsk8ldap.so libgsk8sys.so

    but still the error stays the same

    WTF?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •