Results 1 to 2 of 2
  1. #1
    Join Date
    Jan 2013
    Posts
    1

    Unanswered: Cant uninstall and reinstall postgresql 8.4.

    Cant uninstall and reinstall postgresql 8.4.

    I have tried for about 6 hours now to get it working again.

    There was a problem with the database and I decided it best to reinstall the program.

    Im on W7 64, I used revo uninstaller.

    I also manually deleted the user files 'postgres' and postgres files in the program files folder.

    i used command promt with 'net user postgres /delete'

    when i try to re-install 8.4 i get an error message saying it was unsuccessful.

    I then have to uninstall what was installed that time and i tried different versions.

    postgres 9.0/9.1/8.39 all had errors installing.

    Also i can see after each failed install I get 'postgres.exe' files in process explorer and one of them is using 50% CPU.

    there has to be something im missing. If i uninstalled the program surely when its installed again it would not be using 50% CPU, before it was barely using 3%.

  2. #2
    Join Date
    Dec 2012
    Posts
    43
    I think your problem is the uncompleted deletion of the user account "postgres".
    Deleting the account with "net user ..." don't delete the user profile in "C:\Users" ...
    If you delete manually the user profile directory "C:\Users\postgres" a registry key remains which points to the deleted directory.

    You have to delete the user profile completely.
    You can find a solution at
    Windows 7 reset user profile

    After deletion of the user profile a reboot is recommended.
    Now you can install PostgreSQL again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •