Results 1 to 5 of 5
  1. #1
    Join Date
    Aug 2008
    Posts
    464

    Unanswered: datetime loading - 10g

    Hi guys

    When I'm trying to load a CSV file using the external table staging method, the first 3 columns out of 30 are not loaded in the ext table.

    The log file says:

    LOG file opened at 02/13/13 12:53:06

    Field Definitions for table EXT_000111222
    Record format DELIMITED, delimited by

    Data in file has same endianness as the platform
    Rows with null fields are accepted

    Fields in Data Source:
    RESULT
    Terminated by "," CHAR (500)
    Enclosed by """ and """
    Trim whitespace same as SQL Loader

    and so on.........

    I checked the Internet but nothing for dummies. Any help would be greatly appreciated.

    Regards
    Shajju

  2. #2
    Join Date
    Jan 2004
    Location
    Croatia, Europe
    Posts
    4,094
    Provided Answers: 4
    I'd thought that you - being a forum member for 4+ years - would know how to properly ask a question.

    That would contain CREATE TABLE script, several sample records you'd like to load, control file you wrote, meaningful log file (not pieces you find interesting because I don't see any proof that anything went wrong).

  3. #3
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    Did you do error of commission or error of omission?
    We can't say for sure since we don't know what you actually did do (or not).
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

  4. #4
    Join Date
    Jun 2003
    Location
    West Palm Beach, FL
    Posts
    2,713

    Cool

    Quote Originally Posted by shajju View Post
    Hi guys
    . . . E t c . . .
    Fields in Data Source:
    RESULT
    Terminated by "," CHAR (500)
    Enclosed by """ and """
    Trim whitespace same as SQL Loader

    and so on.........
    I concur you need to to properly post your question.

    On the other hand, try changing this:
    Code:
    RESULT
    Terminated by ","              CHAR (500)
    Enclosed by '"' and '"' -- {single quote}{double quote}{single quote}
    The person who says it can't be done should not interrupt the person doing it. -- Chinese proverb

  5. #5
    Join Date
    Aug 2008
    Posts
    464

    Thanks.

    Thanks guys and apologies for not providing enough details. What I posted really doesn't show anything wrong but the problem is fixed after reconfiguration.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •