Results 1 to 7 of 7
  1. #1
    Join Date
    Jun 2007
    Posts
    74

    Excel 2010 Automation issue

    Guys,

    I am attempting to create a new instance of Excel from Access (also 2010)

    I have a reference set to "Microsoft Excel 14.0 Object Library" in my project.

    I am using the following lines to open a new instance of excel:

    Code:
    Dim oXL  As  Excel.Application  
    Set  oXL =  New   Excel.Application
    Excel never opens, I just get an error that the excel application has stopped working...

    Please help, I have done this many times before and not had a problem

    Brent

  2. #2
    Join Date
    Mar 2009
    Posts
    5,249
    Did you install the Servicepack 1 of Office 2010? The first version of the suite had numerous problems, some of them related to Automation.
    Have a nice day!

  3. #3
    Join Date
    Jun 2007
    Posts
    74
    Yes, Service Pack 1 is installed.

  4. #4
    Join Date
    Jun 2007
    Posts
    74
    I have now uninstalled Office and installed service pack 1. Still no change. Any ideas?

  5. #5
    Join Date
    Mar 2009
    Posts
    5,249
    Not that it will help you much but the problem comes from your system and it should work. I copy/paste the 2 lines of code and successfully tested with Office 2010
    Have a nice day!

  6. #6
    Join Date
    Jun 2007
    Posts
    74
    SOLVED!

    Oracle's Hyperion Essbase addin for Excel was the culprit. I removed it and now everything is fine...

  7. #7
    Join Date
    Mar 2009
    Posts
    5,249
    Thanks for the info!
    Have a nice day!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •