Results 1 to 6 of 6
  1. #1
    Join Date
    Oct 2012
    Posts
    25

    Unanswered: SSIS Integration Scheduled Job

    Hello
    I am getting error when running SSIS package using SQL Server agent. Error description is "Unable to load the package as XML because of package does not have a valid XML format". When I run in the BIDS its working fine.. I tried creating the package again and again in differnt folder locations.. But still the sql server job is showing error. Also I have fixed admin role on the server instance with which i think i can run jobs. I am not sure how to check if I have permissions to access the file though.. But its a local file, so I think I dont have any permissions problem. Now as a second alternative I re created the package in a network drive and still getting the error. Please help.. [Sad]

  2. #2
    Join Date
    Aug 2004
    Location
    Dallas, Texas
    Posts
    831
    Did you check the protection level of package to save sensitive data with EncryptSensitiveWithPassword?

  3. #3
    Join Date
    Oct 2012
    Posts
    25

    Thanku

    No I did not... Can you provide some more details... Please???

  4. #4
    Join Date
    Aug 2004
    Location
    Dallas, Texas
    Posts
    831
    Quote Originally Posted by prathibha44 View Post
    No I did not... Can you provide some more details... Please???
    Open the package and right click the open space in control flow tab. Then choose properties. At the bottom of property page is security. Select dontsavesensitive.

    Are you running package in SQL Agent job from file system or package store in SQL Server?

    Have you checked SQL Agent permissions or set up a proxy account?

    Just a few things to consider.

  5. #5
    Join Date
    Oct 2012
    Posts
    25
    Ya, i did define the protection level...
    Yes I am running SQL Agent Job from File system..

    for your question
    Have you checked SQL Agent permissions or set up a proxy account?

    I have fixed db role on the server but not set up proxy account.. I am using SQL Server Agent Service Account which is the default for me..

  6. #6
    Join Date
    Aug 2004
    Location
    Dallas, Texas
    Posts
    831
    Are you running it in 32bit or 64bit mode? Try changing the step to run in 32bit mode and see if that helps. Which version of SQL Server?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •