Results 1 to 2 of 2
  1. #1
    Join Date
    Dec 2012
    Posts
    30

    Unanswered: SQL ERROR WITH 8.4 VERSION NOT9.0 : syntax errorat or near "do". Stato SQL: 42601

    Hi to All,

    I observ that the error of last post does exist only if i run the function from Postgresql 8.4 version. In fact it does not exist if I run the above function from Postgresql 9.0 function.

    Does someone know the reason?

    Tanks in advance.
    Gianni Pinna.

  2. #2
    Join Date
    Nov 2003
    Posts
    2,935
    Provided Answers: 12
    Anonymous blocks using the DO keyword were introduced in 9.0 so they are not available in earlier releases. This is clearly documented in the manual
    I will not read nor answer questions where the SQL code is messy and not formatted properly using [code] tags: http://www.dbforums.com/misc.php?do=bbcode#code

    Tips for good questions:

    http://tkyte.blogspot.de/2005/06/how...questions.html
    http://wiki.postgresql.org/wiki/SlowQueryQuestions
    http://catb.org/esr/faqs/smart-questions.html

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •