Results 1 to 2 of 2
  1. #1
    Join Date
    Jun 2013
    Posts
    1

    Unanswered: MACH 11 - problem with Connection Manager

    Hi,

    I am trying to set up a connection manager for MACH 11 cluster.
    I have two Informix servers: ids_pri, ids_hdr.


    sqlhosts file on ids_pri:

    ids_pri_185_shm onipcshm 199.10.284.185 ids_pri_185_shm
    ids_pri_185_tcp onsoctcp 199.10.284.185 ids_pri_185_tcp
    ids_hdr_187_tcp onsoctcp 199.10.284.187 ids_hdr_187_tcp
    cluster_tst group - - e=ids_hdr
    ids_pri onsoctcp 199.10.284.185 ids_pri g=cluster_tst
    ids_hdr onsoctcp 199.10.284.187 ids_hdr g=cluster_tst

    /etc/services on ids_pri:

    ids_pri_185_tcp 19993/tcp
    ids_pri 19992/tcp
    ids_hdr 19995/tcp
    idsd 19999/tcp
    ids_hdr_187_tcp 19991/tcp



    sqlhosts file on ids_hdr:

    ids_hdr_187_shm onipcshm 199.10.284.187 ids_hdr_187_shm
    ids_hdr_187_tcp onsoctcp 199.10.284.187 ids_hdr_187_tcp
    ids_pri_185_tcp onsoctcp 199.10.284.185 ids_pri_185_tcp
    cluster_tst group - - e=ids_hdr
    ids_pri onsoctcp 199.10.284.185 ids_pri g=cluster_tst
    ids_hdr onsoctcp 199.10.284.187 ids_hdr g=cluster_tst

    /etc/services on ids_hdr:

    ids_hdr_187_tcp 19991/tcp
    ids_hdr 19995/tcp
    idsd 19999/tcp
    ids_pri_185_tcp 19993/tcp
    ids_pri 19992/tcp



    On ids_pri i have a connection manager config file:

    NAME cluster_tst
    LOGFILE /opt/informix/tmp/cm_cluster_tst.log

    CLUSTER cluster_tst
    {

    INFORMIXSERVER ids_pri_185_tcp, ids_hdr_187_tcp
    SLA ids_pri DBSERVERS=primary
    SLA ids_hdr DBSERVERS=HDR
    FOC ORDER=ids_pri,ids_hdr TIMEOUT=10 RETRY=1
    }



    When i run connection manager with:

    oncmsm cluster_tst -c $INFORMIXDIR/etc/cmsm_tst.cfg


    I get errors in log file:

    14:58:10 IBM Informix Connection Manager
    14:58:10 IBM Informix CSDK Version 4.10, IBM Informix-ESQL Version 4.10.FC1
    14:58:10 Build Number: N638
    14:58:10 Build Host: lxvm-l172
    14:58:10 Build OS: Linux 2.6.18-128.el5
    14:58:10 Build Date: Sat Mar 2 10:07:32 CST 2013
    14:58:10 GLS Version: glslib-6.00.FC1
    14:58:10
    14:58:10 SLA ids_pri listener mode REDIRECT
    14:58:10 SLA ids_hdr listener mode REDIRECT
    14:58:10 Connection Manager name is cluster_tst
    14:58:10 Starting Connection Manager...
    14:58:10 the current maximum number of file descriptors is 32767
    14:58:10 dbservername = ids_pri_185_tcp
    14:58:10 nettype = onsoctcp
    14:58:10 hostname = 199.10.284.185
    14:58:10 servicename = ids_pri_185_tcp
    14:58:10 options =
    14:58:10 dbservername = ids_hdr_187_tcp
    14:58:10 nettype = onsoctcp
    14:58:10 hostname = 199.10.284.187
    14:58:10 servicename = ids_hdr_187_tcp
    14:58:10 options =
    14:58:10 Cannnot find SQLHOST information for -
    14:58:10 ALARM 5001 unable to connect to Informix server no SQLHOST information
    14:58:10 Cannnot find SQLHOST information for -
    14:58:10 ALARM 5001 unable to connect to Informix server no SQLHOST information
    14:58:10 listener ids_pri initializing
    14:58:10 listener ids_hdr initializing
    14:58:10 Warning: Cannot start listener ids_hdr, network error -25572
    14:58:10 Listener ids_pri DBSERVERS=primary is active with 4 worker threads
    14:58:11 ALARM 1002 Error: SLA listener failed, Connection Manager can not start
    14:58:11 ALARM 1002 Failed to switch to daemon mode, Connection Manager stopped


    I checked sqlhosts files several times, i can ping servers and can't find why CM doesn't work.

    Additionally, i checked if dbaccess /connect would work - and it works.
    I've got correct entries in $INFORMIXDIR/etc/hosts.equiv file.

    Any ideas?


    Thanks in advance

  2. #2
    Join Date
    Sep 2004
    Posts
    51

    Mach11 - problem with Connection Manager

    The problem states that the Connection Manager is using hosts.equiv. Is that a miss print. If no did you set the INFORMIXSQLHOSTS environment setting.

    HTH

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •