Results 1 to 2 of 2
  1. #1
    Join Date
    Jul 2013
    Posts
    1

    Unanswered: Innodb disabled, why?

    Hello,

    i Have an Ubuntu 12.04 Server running mysql 5.5.31 and for Magento i need Innodb, but i dont get it enabled.

    Command "show engines;" gives me this:
    Engine: Innodb
    Support: no

    Command "SHOW VARIABLES LIKE 'have_innodb';" gives me this:
    have_innodb | DISABLED

    Command "show engine innodb status;" gives me this:
    ERROR 1286 (42000): Unknown storage engine 'innodb'

    I tried everything, changing the innodb_log_file_size, editing the my.cnf but i dont get innodb running.


    My.cnf file:

    [client]
    port = 3306
    socket = /var/run/mysqld/mysqld.sock

    [mysqld_safe]
    socket = /var/run/mysqld/mysqld.sock
    nice = 0


    [mysqld]
    user = mysql
    pid-file = /var/run/mysqld/mysqld.pid
    socket = /var/run/mysqld/mysqld.sock
    port = 3306
    basedir = /usr
    datadir = /var/lib/mysql
    tmpdir = /tmp
    lc-messages-dir = /usr/share/mysql
    skip-external-locking

    bind-address = 127.0.0.1
    key_buffer = 16M
    max_allowed_packet = 16M
    thread_stack = 192K
    thread_cache_size = 8

    myisam-recover = BACKUP

    query_cache_limit = 1M
    query_cache_size = 16M

    log_error = /var/log/mysql/error.log

    [root@~]# grep innodb /etc/mysql/my.cnf
    innodb_data_home_dir = /var/lib/mysql
    innodb_data_file_path = ibdata1:10M:autoextend
    innodb_log_group_home_dir = /var/lib/mysql
    default-storage-engine=innodb
    #default-table-type=innodb
    innodb_buffer_pool_size = 256M
    innodb_additional_mem_pool_size = 40M
    innodb_log_file_size = 100M
    innodb_log_buffer_size = 4M
    innodb_flush_log_at_trx_commit = 1
    innodb_lock_wait_timeout = 50
    innodb_flush_method=O_DIRECT
    innodb_fast_shutdown = 0

    [mysqldump]
    quick
    quote-names
    max_allowed_packet = 16M

    [isamchk]
    key_buffer = 16M

    !includedir /etc/mysql/conf.d


    I really have no more Ideas, i hope you can help me.

  2. #2
    Join Date
    Sep 2009
    Location
    San Sebastian, Spain
    Posts
    880
    Have you checked that the my.cnf has not disabled InnoDB? There is a parameter --innodb=YES which if innodb has been compiled into the binaries will enable it. Check the documentation MySQL :: MySQL 5.5 Reference Manual :: 14.3.4 InnoDB Startup Options and System Variables
    Ronan Cashell
    Certified Oracle DBA/Certified MySQL Expert (DBA & Cluster DBA)
    http://www.it-iss.com
    Follow me on Twitter

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •