Results 1 to 4 of 4
  1. #1
    Join Date
    Jul 2013
    Posts
    6

    Unanswered: Wizards not working in Access 2013

    Hi all,
    Really hoping someone can help - at my wits end!
    I am running Access 2013 from office professional 64 bit on a laptop running Windows 7 64-bit.
    For some reason the wizards are not working. Initially I noticed it when adding controls to a form, but when trying to import data from an Excel spreadsheet and create a new table from it, the same error popped up. The message box that popped up said:
    "The code contains a syntax error, or a Microsoft Access function you need is not available.If the syntax is correct, check the Control Wizards subkey or the Libraries key in the Microsoft Access section of the Windows Registry to verify that the entries you need are listed and available. If the entries are correct, either you must correct the Microsoft Access Utility Add-ini, or the file acWzlib or this wizard has been disabled. To reenable this wizard, run Microsoft Access or Microsoft Office Setup again to reinstall Microsoft Access. Before you reinstall Microsoft Access, delete the Windows Registry keys for the Microsoft Access Utility Add-in and acWzlib.

    I have searched the internet for options, and so far have tried:
    1. Repairing office
    2. Uninstalling office and reinstalling it
    3. Deleting all keys I can find in the registry for Office before reinstalling
    4. Running the Microsoft Office 'Fix' for complete uninstall of Office before reinstalling
    5. Running a disk scan to find bad sectors (none found)
    6. Running a virus check (no viruses found, McAfee free version used)
    7. Checking disabled Addins (none listed)
    8. Ensuring the 'Controls Wizard' Toggle was on
    9. Apparently Office 2010 had this issue with the 64 bit version and this was fixed by changing the extension of a number of files with .old, and then having Access fix this by reinstalling them automatically.

    Unfortunately, although I am proficient with Excel and Word, I know next to nothing about Access and so really need these Wizards! Does anyone have any ideas about how to fix this issue?

    The error message does mention 'check the control wizards subkey or the libraries key'. I assume this means in the registry, but don't know what the entry should look like (and although I know how to delete, not sure how to add it!)

    Many thanks!

  2. #2
    Join Date
    Jul 2013
    Posts
    6
    OK, rather embarrassingly shortly after writing this I had a brainwave and have solved the problem. In case anyone had the same issue:

    Even after a fresh install of Office, it would seem that the 'trusted location' of the wizards was wrong. Clicking File->Options->Trust Center->Trust Center settings->Trusted Locations brings up the locations Access will trust. For me, a trusted location was C:\Program Files\Microsoft Office 15\Root\Office15\ACCWIZ\. Checking the file structure, though, the ACCWIZ folder was found at C:\Program Files\Microsoft Office\Office15\ACCWIZ\. I clicked 'Add new location', navigated to this folder, and problem fixed.

    I hope that this helps someone!

  3. #3
    Join Date
    Apr 2014
    Posts
    1

    Thumbs up It Worked! Thank You!

    Have had & used Office 2013 for more than a year, but had no reed to use Access until very recently. Up popped this `no wizard' issue. Called MS Tech Support after spending hours on their FAQ sites, etc. No luck there. They said I needed to call back and give them $50 and, maybe, they could help.

    Kept looking around and found your issue, then follow-on success. Tried it. Voila! Within 5 minutes of reading your guidance my Access wizards were working Fine.

    I also now have another `thing' to watch out when troubleshooting MS programs.

    Thanks for your perseverance and reporting your issue in this forum.

    It DEFINITELY helped me.

  4. #4
    Join Date
    Aug 2015
    Posts
    1

    Red face It helped me!

    Quote Originally Posted by Gronwold View Post
    OK, rather embarrassingly shortly after writing this I had a brainwave and have solved the problem. In case anyone had the same issue:

    Even after a fresh install of Office, it would seem that the 'trusted location' of the wizards was wrong. Clicking File->Options->Trust Center->Trust Center settings->Trusted Locations brings up the locations Access will trust. For me, a trusted location was C:\Program Files\Microsoft Office 15\Root\Office15\ACCWIZ\. Checking the file structure, though, the ACCWIZ folder was found at C:\Program Files\Microsoft Office\Office15\ACCWIZ\. I clicked 'Add new location', navigated to this folder, and problem fixed.

    I hope that this helps someone!
    Thank you so much!

    However I'll place a note here because the folders were slightly different for me. The trusted location that the Access install put in for me was C:\Program Files(x86)\Microsoft Office 15\Root\Office15\ACCWIZ whereas my actual ACCWIZ folder was in C:\Program Files\Microsoft Office 15\Root\Office15\ACCWIZ . Adding this as a trusted location resolved the problem & my despair.

    Thanks again :-)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •