Results 1 to 3 of 3
  1. #1
    Join Date
    Jul 2013
    Posts
    2

    Unanswered: I/O error while trying to create or restore DB

    Using DB2 v9.7.0.4 (Fix Pack 4)

    During an attempted restore: RESTORE DATABASE <db_name> FROM <path> LOGTARGET <log_path>, getting the following error:

    SQL10004C An I/O error occurred while accessing the database directory.
    SQLSTATE=58031

    I'm getting the same error when I try to create an empty database: CREATE DATABASE <db_name>.

    I'm just trying to get the system back into a state where I can re-create the database.

    Looked up SQL10004C on IBM's Information Centre, but this did not solve my problem. LIST DB DIRECTORY shows that the directory is empty, which is correct. Tried moving the files under <inst_home>/sqllib/sqldbdir as suggested, but this does not appear to have any effect, even after a db2stop/db2start.

  2. #2
    Join Date
    Jul 2013
    Location
    Moscow, Russia
    Posts
    666
    Provided Answers: 55
    What does appear in the ~/sqllib/db2dump/db2diag.log file after the RESTORE / CREATE DB commands?
    Regards,
    Mark.

  3. #3
    Join Date
    Jul 2013
    Posts
    2
    Thanks for the reply, I actually just figured it out a moment ago and was on my way back here to say as much...

    It seems that it was a file in ~/<instance_user>/<node>/sqldbdir/ that was causing the problem, removing it and restarting has solved the problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •