Results 1 to 5 of 5
  1. #1
    Join Date
    Aug 2013

    Unanswered: Problem with DB2 Data Studio Administration Client [solved]

    Hello everyone,

    two days ago I installed the DB2 Express C v10.5 on my laptop (Windows 7 Home Premium 64bits) in order to start learning the language and get the hangs of the Data Studio environment. There is a sample database included in the DB2 Express installation with the name "SAMPLE". So far I haven't managed to connect to it. I constantly receive the following error

    Could not connect to SAMPLE.
    Error creating SQL Model Connection connection to SAMPLE. (Error: [jcc][t4][2057][11264][3.63.108] The application server rejected establishment of the connection.
    An attempt was made to access a database, SAMPLE, which was either not found or does not support transactions. ERRORCODE=-4499, SQLSTATE=08004)
    Then I try to create a new database on localhost, but i receive the following error:
    Failed to execute command. DAS returned the following error: sqlcode=-22223 output=null

    I am stuck for good and I really do not know what to do. I deactivated the firewall, although the connection is local. I just try to make something work and I can't...

    --- Versions Info ---
    DB2 -> v10.5.0.420 (64 bits)
    Fix Pack -> 0
    name: "DB2 Express-C"
    License type: "Unwarranted"
    IBM Data Studio -> v3.1.1.0
    OS: Windows 7 Home Premium 64bits

    Please help.
    Last edited by makisffx; 08-19-13 at 14:33. Reason: Additional information regarding the versions (forum rules)

  2. #2
    Join Date
    Aug 2013

    A little progress...

    Apparently, it seems that something is going on with the Data Studio. I succeeded in connecting to "SAMPLE" database, realizing common administrative tasks, as well as posing sql commands through "db2 command window - Administrator". The database server has no obvious problem.

    If I am to guess something, I would say that there is some kind of incompatibility between the DB2 Express-C (v10.5) and Data Studio (v3.1.1).

    Can anyone confirm that?

    (There is already Data Studio v4.1, but I am not able to download it. It seems I cannot create a proper IBM account. Don't know why... )

  3. #3
    Join Date
    Aug 2013

    Problem solved.

    There is a compatibility issue between the DB2 version and the Data Studio one. Installed Data Studio v4.1 and everything works just fine!

  4. #4
    Join Date
    Oct 2013

    I even have the DS 4.1 and DB2 v10.5 but am still facing the same issue, I dont think its a compatiblity issue...its something else which is resulting this problem.

    Does anyone else have any resolution to this problem.

  5. #5
    Join Date
    Sep 2014
    Hey i am also facing the same problem, have you find any solutions for the same?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts