Results 1 to 4 of 4
  1. #1
    Join Date
    Oct 2012

    Unanswered: 229 - Could not open or create a temporary file.

    Hi I have a Informix 11 running on linux and I am trying to run below command

    dbschema -d db01 > t

    and getting below error and I did grant dba to the mentioned user

    DBSCHEMA Schema Utility INFORMIX-SQL Version 11.70.FC5DE
    grant dba to "user01";

    -229 - Could not open or create a temporary file.
    -131 - ISAM error: no free disk space

    How to fix this

    Thanks and Regards

  2. #2
    Join Date
    Oct 2012


    Hi Guys, did some reading and below are my solution, hope this is wha tI should doo and hope will help some one

    there was not DBSPACETEMP defined and below what I did to get around the issue

    Adding temp dbspace

    Using raw devicess

    onspaces -c -t -d temp_space -p /dev/raw_dev1 -o 5000 -s 5120

    Using local file (cooked files)

    toush /home/informix/as_chunks/temp_space01
    chmod 660 /home/informix/chunks/DATADBS01.01
    onspaces -c -t -d temp_space -p /home/informix/as_chunks/temp_space01 -o 0 -s 102400

    now you need to find the onconfig file that you are using and tell the instant that you have created the dbspace (temp)

    open onconfig file
    find DBSPACETEMP and modifi as below

    DBSPACETEMP <if existing>:temp_space:temp_space01:temp_space...... ......

    Restart the instant

    onmode -ky (stop)
    oninit (to start)

    Thanks and Best Regards

  3. #3
    Join Date
    Sep 2011
    Pont l'Abbé, Brittany, France
    Provided Answers: 1

    you found by yourself :-)

    I would suggest to use oninit -v to start the engine, this will give you more details on the start phase, which can be handy in case of problems...

  4. #4
    Join Date
    Oct 2012
    Hi begooden-it, yes was doing a bit of google and found this and tried, worked

    Thank you for the reply

    Best Regards

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts