Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2013
    Posts
    2

    Unanswered: UTF-8 issue junk characters are coming for japane chars

    Hi,
    We have to get some data from U98 (saixdbU98) in UTF-8 format in Excel sheet.

    We are having queries ready for this. These queries bring data which have Japanese characters.

    We are having the access to run the Select query through pbrun (Power Broker). But when we run the Select queries through pbrun (Power Broker) then in the result Japanese chars are garbled. It comes in Text format.

    Please suggest a solution for this and let us know what process we have to follow to get the result in UTF-8 format in Excel sheet.
    ----------------------------------
    --

    set sqlblanklines on;
    SET DEFINE OFF;

    set linesize 1000

    set long 1000000

    set pages 50000

    set feed off markup html on spool on

    spool /tmp/UAT_bkp_xls_27Aug12.xls


    --UAT_bkp_xls_27Aug12.sql


    select * from GCMS_USER.GCMS_PHRASES ;

    select * from GCMS_USER.GCMS_MAPPING ;

    select * from GCMS_USER.GCMS_SCREEN ;

    select * from GCMS_USER.GCMS_APPS ;



    commit;

    spool off
    set markup html off spool off

    exit;








    This is the code..please suggest me if I can add any parametrs in this file to remove junk characters

    thank you

  2. #2
    Join Date
    Aug 2013
    Posts
    2

    utf-8 issue japanese chars are comong as ???

    Hi,
    We have to get some data from U98 (saixdbU98) in UTF-8 format in Excel sheet.

    We are having queries ready for this. These queries bring data which have Japanese characters.

    But when we run the Select queries then in the result Japanese chars are garbled. It comes in ????.

    Please suggest a solution for this and let us know what process we have to follow to get the result in UTF-8 format in Excel sheet.
    here is the code

    --

    set sqlblanklines on;
    SET DEFINE OFF;

    set linesize 1000

    set long 1000000

    set pages 50000

    set feed off markup html on spool on

    spool /tmp/UAT_bkp_xls_27Aug12.xls


    --UAT_bkp_xls_27Aug12.sql


    select * from GCMS_USER.GCMS_PHRASES ;

    select * from GCMS_USER.GCMS_MAPPING ;

    select * from GCMS_USER.GCMS_SCREEN ;

    select * from GCMS_USER.GCMS_APPS ;



    commit;

    spool off
    set markup html off spool off

    exit;

  3. #3
    Join Date
    Jan 2003
    Location
    Massachusetts
    Posts
    5,799
    Provided Answers: 11
    This appears to be an Oracle question, rather than a SQL Server question. Have you made sure that the client machine's NLS settings are properly set to UTF-8? Specifically NLS_Lang. Remember, this has three parts.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •