Results 1 to 4 of 4
  1. #1
    Join Date
    Aug 2013
    Posts
    80

    Unanswered: Activated AUTO_RUNSTATS

    Hi Everyone,
    I am using DB2 ver 9.7.6 running in AIX 7.1 Server.

    My question is anyone activated the AUTO_RUNSTATS in Datawarehouse Environment before as we encounter issues that once activated, the whole query get slower (extremely slow compare to before). 15mins become 3 hours.
    Also found that the clusterratio become -1, with normal runstats ( db2 " RUNSTATS ON TABLE DSSBDW.AR_AVY_SHD AND INDEXES ALL SHRLEVEL CHANGE" ), it will update the clusterratio. In fact, after we ran the normal runstats, the query finished immediately. Anything I miss out immediate after I activated AUTO_RUNSTATS ?


    Please share your thought on this. Thanks.

  2. #2
    Join Date
    Aug 2008
    Location
    Toronto, Canada
    Posts
    2,367
    I don't trust AUTO maintenance and have AUTO_MAINT turned off for all databases.

  3. #3
    Join Date
    Jan 2009
    Location
    Zoetermeer, Holland
    Posts
    746
    Quote Originally Posted by ckwan123 View Post
    Anything I miss out immediate after I activated AUTO_RUNSTATS ?
    Did you create the runstats-profiles for all tables?
    Somewhere between " too small" and " too large" lies the size that is just right.
    - Scott Hayes

  4. #4
    Join Date
    Aug 2013
    Posts
    80
    No, should I have runstats profile for each individual tables ? What's the purpose of this profile for, is this one of the pre-requisite for auto_runstats enablement ? Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •