Results 1 to 6 of 6
  1. #1
    Join Date
    Oct 2013
    Posts
    5

    Unanswered: DB2 Data Warehouse Center v8

    Good morning.

    We're running a DB2 v8 LUW system on AIX that includes Data Warehouse Center. It seems that not many people have used or heard of this product, even when it was in support and still being sold!

    We have the need to move the system and upgrade the database to version 10.5. The product isn't included with versions 9 or 10, so we will have to install from the v8 install set that we have.

    The obvious questions are:

    1) Will this product work when installed next to a 10.5 (or 9) database?

    2) The Windows tools come as part of the version 8 Admin Client. Therefore, can we continue to use this admin client but connecting back to version 10 databases (or 9)?

    I fear that our only real option is to migrate all of the Warehouse Center content onto Data Stage (ready and waiting), but this is going to take many months and cost a lot of time. Thus, we're being pressured to upgrade for now.

    Thoughts and experiences are welcome!

    Thank you very much database people

  2. #2
    Join Date
    Jun 2003
    Location
    Toronto, Canada
    Posts
    5,516
    Provided Answers: 1
    I can't tell you anything about Data Warehouse Center, but I very much doubt that it will work with up-level DB2 versions. DB2 clients usually support connecting to servers two versions down and one version up, so you might have some luck with DB2 9.1 (which itself is not supported anymore).
    ---
    "It does not work" is not a valid problem statement.

  3. #3
    Join Date
    Jul 2013
    Location
    Moscow, Russia
    Posts
    666
    Provided Answers: 55
    Quote Originally Posted by igglebert View Post
    1) Will this product work when installed next to a 10.5 (or 9) database?

    2) The Windows tools come as part of the version 8 Admin Client. Therefore, can we continue to use this admin client but connecting back to version 10 databases (or 9)?
    Hi,

    db2 v8 client (and Data Warehouse Center) will not work with v10.5 server directly.

    But you can try this:
    v8 DB2 Client -> v9.7 DB2 Connect -> v10.5 DB2 Server
    It should work in theory...
    Regards,
    Mark.

  4. #4
    Join Date
    Oct 2013
    Posts
    5
    Thanks for the responses.

    I'll test it out and see, but you may be right. I'm putting the same questions to IBM but the product is out of support and the support was terrible when it was *in* support

  5. #5
    Join Date
    Apr 2012
    Posts
    1,035
    Provided Answers: 18
    It must be a decade since DB2 V8 was announced.
    Lots has changed in the meanwhile.
    Looks like your shop needs a carefully thought out migration plan.
    But if you have also new hardware, run both old and new versions in parallell on separate hardware, and do a piece by piece migration - carefully costed and agreed with the stakeholders.

  6. #6
    Join Date
    Oct 2013
    Posts
    5
    Quote Originally Posted by db2mor View Post
    It must be a decade since DB2 V8 was announced.
    Lots has changed in the meanwhile.
    Looks like your shop needs a carefully thought out migration plan.
    But if you have also new hardware, run both old and new versions in parallell on separate hardware, and do a piece by piece migration - carefully costed and agreed with the stakeholders.
    Yes, the solution is simple, migrate to the new tools that already exist. Unfortunately due to politics and lack of funding, this has fallen out of favour for the foreseeable future. Having been left with this legacy system, other groups in the enterprise need it to be upgraded and moved.

    Anyway, I'll put the technical risks on the table and let others decide.
    Last edited by igglebert; 10-07-13 at 12:35. Reason: Typos

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •