Results 1 to 6 of 6
  1. #1
    Join Date
    Jul 2013
    Posts
    31

    Unanswered: Not able to use db2set,

    When trying to connect to a database im getting the following error.

    SQL0332N Character conversion from the source code page "819" to the target
    code page "UNKNOWN" is not supported. SQLSTATE=57017

    I tried to set the following

    db2set db2codepage =931

    I got the following error.

    DBI1302E Invalid parameter detected.

    Explanation:

    An invalid parameter was used.

    User response:

    Use the -? option for the usage help message.

    Please help me resolve this.
    DB2 version:9.7.0
    Platform: AIX

    I have updated the instance, but its of no use. Im still getting the same error.

  2. #2
    Join Date
    Jun 2003
    Location
    Toronto, Canada
    Posts
    5,516
    Provided Answers: 1
    DB2CODEPAGE is an environment variable, not a DB2 registry variable. Use the shell EXPORT command to set it.
    ---
    "It does not work" is not a valid problem statement.

  3. #3
    Join Date
    Jul 2013
    Posts
    31
    Ok, Now i've set the DB2CODEPAGE. But Im still not able to connect to the database.
    I'm still getting the following error.

    SQL0332N Character conversion from the source code page "819" to the target
    code page "UNKNOWN" is not supported. SQLSTATE=57017

  4. #4
    Join Date
    Apr 2012
    Posts
    1,035
    Provided Answers: 18
    What is the output of "locale -a" on your AIX login?
    What is the value of the LANG variable in your AIX shell?
    Ask your DB2 DBA to tell you the codepage of the DB2 database to which you are trying to connect.
    Are you sure that you are at fixpack-0 of V9.7 ?
    Is your AIX client remote from the DB2-server? (or is it running on the same machine)?

  5. #5
    Join Date
    Jul 2013
    Location
    Moscow, Russia
    Posts
    666
    Provided Answers: 55
    Hi,

    You can set DB2CODEPAGE as an environment variable or as a DB2 registry variable.
    You got the error on 'db2set db2codepage =931' since space between 'db2codepage' and '=' is not allowed.

    Try this in the command line:
    Code:
    db2set DB2CODEPAGE=
    DB2CODEPAGE=1208
    db2 terminate
    db2 connect to yourdb ...
    db2 "select value from sysibmadm.dbcfg where name='codeset'"
    What is the result of the select statement?
    Regards,
    Mark.

  6. #6
    Join Date
    Dec 2008
    Posts
    44
    try:
    db2set db2codepage=931

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •