Results 1 to 8 of 8
  1. #1
    Join Date
    Feb 2013

    Unanswered: Upgrade db2 instance from 9.7 to 10.1 to 10.5


    as a test, before upgrade at my client I have created a virtual machine with Linux RHEL 6.2 and a DB2 and attempted to upgrade it to 10.5.

    In the DB2 manual for 10.5 upgrades it says that upgrade from 9.7 to 10.5 is possible directly.

    I installed the binaries in parallel with 9.7 (as it says in the docs), stopped the instance (also the database is single instance without hadr) and ran db2iupgrade db2inst1. I received the following output:

    DBI1446I  The db2iupgrade command is running.
    DB2 installation is being initialized.
     Total number of tasks to be performed: 4 
    Total estimated time for all tasks to be performed: 309 second(s) 
    Task #1 start
    Description: Setting default global profile registry variables 
    Estimated time 1 second(s) 
    Task #1 end 
    Task #2 start
    Description: Initializing instance list 
    Estimated time 5 second(s)
    I left it to work, but after an hour it hasn't changed. There was nothing in the db2iupgrade.log (except for the same message as posted above) and nothing in the db2diag.log (level 4 debug). And I mean absolutely nothing, not one line ...

    OK, so I decided to take things slow. I installed the 10.1 binaries and the upgrade went fine. I upgraded the instance and the database without any problems. So I went from there, I installed the 10.5 binaries again (I uninstalled them before 9.7 to 10.1 upgrade), stopped the instance and ran: db2iupgrade db2inst1 again.

    I received the same message as I got from my first attempt to upgrade to 10.5 and another hang...

    The weird thing is that when I upgraded HADR on another machine from 10.1 to 10.5 everything went fine.

    Does anyone have similar problems ? Maybe any ideas what I am doing wrong or if there are any other logs I can check beside db2diag.log and db2iupgrade.log ?

    Thanks in advance and best regards

    - kwhtre

  2. #2
    Join Date
    Dec 2008
    Did you call DB2 support?

    Sometimes, issuing "db2 terminate" couple of times before starting/after stopping the process in the middle clears any background process.

  3. #3
    Join Date
    Feb 2013
    No I didn't call DB2 support.

    I did however issue 'db2 terminate' a couple of times and stopped all db2 services before instance upgrade and the problem persists...

  4. #4
    Join Date
    Apr 2012
    Provided Answers: 17
    Some suggestions...

    Have you checked the resources you are giving to the VM? (ram and cpu)

    On RHEL I find that it is often necessary to manually configure the kernel parameters as directed by the docs (even though it's supposed to be automatic). So, check your RHEL kernel parameters before running db2ckupgrade.

    What options are you giving to the v10.5 db2iupgrade ?

    Are you using the fully qualified pathname to start db2iupgrade
    e.g. /opt/ibm/db2/V10.5/instance/db2iupgrade .... ?

    When you became the root user, did you use su - root (so the environment is the same as if you had done a login as root) ?

    Also confirm you did not dot-in or source the db2profile when you became root.

    You might try using the -d (debug) option and seeing if there are any more clues in the /tmp/db2ckupgrade.log.XXXXX file.

    Also when you get the hang you might check /var/log/messages to see if there is anything unusual recorded around the time of the hang.

    Lastly try uninstalling V10.5, and installing V10.5 fixpack 2 to see if that makes any difference.

  5. #5
    Join Date
    Feb 2013
    Thank you for your suggestions. I have tried them, however nothing worked so far.

    Currently I have installed the 10.5 fixpack 2 and am trying with the instance upgrade right now. Unfortunately the upgrade has stopped at the same step as before. I will give it another 10 minutes just to be sure but it doesn't look good.

    The funny thing is that whenever I interrupt the instance upgrade process (after a lot of time of inactivity) the output is : "Program db2iupgrade completed successfully." even though the instance is not upgraded. db2level output remains:

    'Informational tokens are "DB2 v10.1.0.0"'

    If anyone has any suggestions, please reply.
    I'll post if I figure something out...

    Thanks and best regards,

  6. #6
    Join Date
    Feb 2013
    OK so here might be some new info:

    If I do a db2ilist from 10.1 installation it returns the correct instance name. If I do that from 10.5 installation it returns nothing:

    [root@db2testupgrade ~]# /opt/ibm/db2/V10.1/bin/db2ilist 
    [root@db2testupgrade ~]# /opt/ibm/db2/V10.5/bin/db2ilist 
    [root@db2testupgrade ~]#
    But I presume that this is because the V10.1 is still the acting version. The instance has not yet been upgraded. (because it halts at step 2 like mentioned above)

    Also, I checked the kernel parameters and they appear fine, and here is the db2ckupgrade output with the -d switch:

    [db2inst1@db2testupgrade instance]$ pwd
    [db2inst1@db2testupgrade instance]$ ./db2ckupgrade -d testdb -l ~/testupgrd.txt 
    ## Entering: call_db2ckmigexe
    ## Entering: find_mighome db2inst1
    ## Home directory of instance to upgrade is /home/db2inst1
    ## Entering: query_instuse_string db2inst1 V PRE_V9
    ## Entering: find_homedir db2inst1
    ## User home dir = /home/db2inst1
    ## Exiting: find_homedir
    ## Exiting: query_instuse_string
    ## Entering: query_instuse_string db2inst1 INSTVER 0
    ## Entering: find_homedir db2inst1
    ## User home dir = /home/db2inst1
    ## Exiting: find_homedir
    ## Exiting: query_instuse_string
    ## Entering: query_instuse_string db2inst1 DB2DIR /opt/ibm/db2/V10.5
    ## Entering: find_homedir db2inst1
    ## User home dir = /home/db2inst1
    ## Exiting: find_homedir
    ## Exiting: query_instuse_string
    ## Exiting: find_mighome
    ## Entering: find_mighome_internal db2inst1
    ## Exiting: find_mighome_internal
    ## Entering: InstanceBitWidth
    ## Entering: find_homedir db2inst1
    ## User home dir = /home/db2inst1
    ## Exiting: find_homedir
    ## Exiting: InstanceBitWidth
    DBT5508I  The db2ckupgrade utility completed successfully. The database or databases can be upgraded.
    ## Exiting: call_db2ckmigexe
    ## Entering: restoreLibVars
    ## Exiting: restoreLibVars
    Last edited by kwhtre; 11-05-13 at 04:52.

  7. #7
    Join Date
    Apr 2006
    Provided Answers: 11
    correct - upgrade has to run to transfer the instance
    maybe db2ls can check if all installed
    Best Regards, Guy Przytula
    Database Software Consultant
    Good DBAs are not formed in a week or a month. They are created little by little, day by day. Protracted and patient effort is needed to develop good DBAs.
    Spoon feeding : To treat (another) in a way that discourages independent thought or action, as by overindulgence.
    DB2 UDB LUW Certified V7-V8-V9-V9.7-V10.1-V10.5 DB Admin - Advanced DBA -Dprop..
    Information Server Datastage Certified

  8. #8
    Join Date
    Feb 2013
    All right never mind, I managed to upgrade the instance.

    I used:
    db2iupgrade -d -k <instance_name>

    instead of only:
    db2iupgrade <instance_name>

    and that did the trick.

    the -k switch is: "Keeps the pre-upgrade instance type if it is supported in the DB2 copy from where you are running the db2iupgrade command. If this parameter is not specified, the instance type is upgraded to the default instance type supported." - if anyone runs in the same problem as me.

    Thanks everyone for your help - the problem is solved now and I'm happy

    Best regards,

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts